Embedding TTF issue

Previous topic - Next topic


I'm having an issue embedding a TTF into a PDF.
I'm looking to have the PDF into X-1a 2001 (suitable for use on sites such as DriveThruRPG).
The font I am using is Kingthings Calligraphica 2 Regular and Light versions https://www.fontsquirrel.com/fonts/Kingthings-Calligraphica
I have no problems with the Gadugi TTF, it works just fine...

There are file issues of all sorts, including it creating a 165Mb PDF (despite mostly containing relatively small greyscale JPGs except for a limited colour JPG cover image). Even changing it to export as a 100dpi, instead of 300dpi, still leaves me with a huge file.

So I'm not sure what is going wrong.
Is it doing something stupid like embedding every font I have?
I've tried all of the things I can find about embedding fonts, and they've not worked yet.

This is without the apparent alchemy required to create a Table of Contents.

Using Scribus 1.4.6 on a Win10 machine.


what are the signs of troubles you get when embedding that font in the pdf?
is the text outlined?

if it's so, generating the pdf with 1.5.3 might be a solution for you.
just keep in mind, that you should not save a file in 1.5.3 if you want to re-open it in 1.4.6.
so, first make a copy of your .sla and open that copy in 1.5.3.
just to be sure you don't do anything wrong.



When I open it on my machine with Microsoft Edge, the parts with that font do not display but the gap is there.
When I open it on my machine with Chrome, it shows perfectly.
When I gave it to someone else via a DropBox, it showed the font but garbled the text.

As far as errors go, I get nothing about that. I get warned some text boxes are being covered by others, but I knew that already because I am covering the page numbers in places with images.


Here is the file. Tried in 1.5.3. This file spat out a 169Mb file this time.
There is a 300kb file difference less for Subset All rather than Embed All.

[attachment deleted by admin]


since i don't have your fonts nor the images, i've replaced them with one random font installed on my computer.

with 1.5.3, i can then produce a pdf with a size of 901 Kb.

so, the issue might be with the quality of the fonts you're using (and scribus being forced to outline them) or by a big image you're including.

hard to say from here...