Scribus can't find Ghostscript

Previous topic - Next topic


I installed Scribus Version 1.4.6
03 January 2016
Build ID: C-*-T-*-C1.8.6-Windows
Windows Vista Home 32

I then downloaded and installed Ghostscript.
When I start Scribus I get an error message that Ghostscript is not installed on my system.
Went to File>Preferences>External Tools and set the correct path to Ghostscript using the change button.
Still getting the error message.
Any ideas?


Welcome to the forum Drew.

Odd one that. Are you pointing Scribus to the gswin32.exe instead of the required gswin32c.exe?
Just as a check, mine is pointing to: C:\Program Files\gs\gs9.18\bin\gswin64c.exe (for 64-bit rather than 32-bit)


Thanks for the tip Garry P. I think that is my problem. I only have gswin32.exe installed. Will look for the other version and install it.


I found a site that has gswin32c.exe and downloaded it. Put in it's own directory 'Ghost Script'. Pointed Scribus to it but still get the same error message.


in most cases you don't need ghost script.

start using scribus and don't care about gs for now.

if you get too bored of clicking it away you can then check why scribus is not finding it on your computer.


If you get Ghostscript from an official/approved source then you should automatically get the files needed by Scribus.

I realise that you probably did what you said above just to see if you could get things running but picking individual files off the internet and scattering them around your hard drive is not good practice. You could end up in a right old mess with different applications using different versions of the same software, or worse. A full and consistent installation is best.

* For Windows, one good place to get GS from is here:

* For Mac, you can get GS from here: (full Mac installation instructions are here: )

* For Linux, is one source but it really depends on which flavour/version of Linux is being used (too many options to go into here).

If you install an official/approved copy of GS then you shouldn't have to hunt around for extra files, however you need to make sure that you get the right flavour of GS. Make sure it's the "Postscript and PDF interpreter/renderer" and not the PCL, PXL, XPS or PDL versions. (These other versions might also work but they're not needed and you could end up complicating things.)

I would suggest un-installing whatever GS you've installed and install a "proper" version instead and see what happens.

As a.l.e has said above, Scribus doesn't need GS installed to run. As per the Mac installation instructions: "[GS] allows you to import PostScript (PS) images, Extended PostScript (EPS) images, and PDF files (as images). It also allows you to export your document as PS or EPS (rather than the normal PDF export). It is also needed if you want to use the "Print Plate" Preview functions." If you don't need to do any of these things then you don't need GS.

However, Scribus will keep telling you that GS is not installed every time it runs even if you don't need these functions. This can be annoying. For instance, GIMP doesn't keep telling you that G'MIC is not installed, so why should Scribus keep telling you that GS is not installed? If GS was a requisite then it should come packaged with Scribus, otherwise Scribus should not be so fussy about it not being there.

When you first run Scribus it does a check to see if GS is installed. If it finds GS it adds the path automatically and everything is fine. Why Scribus doesn't check for GS every time it runs - until a path has been set - is a mystery to me. That would alleviate the need for the user to have to manually add the path once GS has been installed. The code to find GS is already there, so why only ever use it once? A strange situation.

At the same time, I think that the pop-up message about GS not being installed should be removed and replaced with a message on the splash screen saying that Scribus is running "without Postscript support" (or some better message which properly portrays the situation). The various PS functions can then be greyed-out until GS has been installed. Greyed-out PS functions with an obvious note (on the splash screen) telling the user they don't have GS installed would be more than enough to tell the user that more functionality could be available if they need it without being annoying.

That's just my view of course. I'm sure there will be arguments against what I've said above but I don't think I've said anything that is particularly unreasonable.


garry, the message has been changed in 1.5.x and it only pops up when scribus really needs gs![]=/@19178&compare[]=/@19179


That's good to know, thanks for pointing that out a.l.e.

Drew, I would not recommend moving to 1.5.x just to stop the message from popping up. There should be ways to fix your current problem - see above - that are better than moving over to developmental software.


Been away awhile so sorry for the late reply.
GaryP and a.l.e. you guys are AWSOME!!!! Took a newbie by the hand and showed the way.
Went to the download site GaryP provided downloaded the correct file and all is well.
Will stick with V 1.4.6.
Thank you for your help.


Glad you've managed to get things sorted Drew. I hope you like using Scribus.