Image disappears on export (solved) Text not exporting (not solved)

Previous topic - Next topic


Well now, when I start to Export my book cover to my desktop, solve my Preflight Verifier issues (not so fast), select export, and then select pdf.  A dialog box pops open and (as an aside) identifies my "current file" as Postscript, I assume having been automatically assigned since I did nothing to the contrary.  I'm offered several flavors of pdf-, none of which are the pdf-x-1a I am told, in this case by Ingram/Spark, that is required.  To be clear I suspect that this is probably a distinction that will be solvable after the mess I'm in at the moment is caught up. (I did finally solve this one later via Google.)

I choose one of the pdf's offered other than pdf-x-1a, since I'm only saving to my own desktop and click Export.  The export shows up on the desktop as an .sla.  That is where the first horror begins (please know that I've spent hours on Google and reading the manual before posting this).

When I completed the export, my book cover looks fine (see screen shot).  Please note, and it might be important, all the inserted frames are outlined in a pale red.  All is well it seems and so to organize my desktop a little I put the image, that I had imported on to my desktop as a .tiff, into one of OS X 10.11.6's folder icons.  It was then inside this little folder and not visible as a file icon on the desktop.

At some point I re-opened the saved desktop export and was confronted with this (see second screen shot).  Initially the opened export has only the bright red X with the imported image name "mountain.tiff" in a stark white box in the middle with the frames shown in pale pale orange.  No amount of clicks changes anything except the locations of the bright red handle frame.

I pulled the image out of the little folder icon back onto the desktop as its own file icon and by its presence as such, it repopulates into the image box, sometimes I click something but randomly it seems to reappear in the book cover again on its own.  I save and close the whole file to my desktop again and reopen it, voila, the image is there again.  All seems right with the world--so long as the image, "mountain.tiff" sits as a file icon on my desktop--not (hidden) inside a folder icon.  One additional note, while the book cover looked fine again and was--open, I took the image file on the desktop and put it back into the folder while the book cover was still sitting open on my desk, the image disappeared from the book cover as I watched--without closing.

Needless to say, I think something will be terribly wrong if I send this file out into the mean and expensive printer-world that doesn't know the image is visible on my desktop, not in a folder thereon.  If it helps, the Preflight Verifier now shows: " Image3  Missing Image (black square)  Background", however this time I know what the problem is.  If it might be important, I note that the properties window shows the image named as "mountain.tiff" not as "Image3".  My route for getting the image was File > Import > Get Image and selecting "mountain.tiff" while it sat on the desktop.

I had a random thought when reloading the image for the millionth time that maybe at > Get Image, I should try choosing the desktop folder icon and opening that to choose the image from inside it rather than from its own file icon dragged to the desktop.  And damn, after two days and making you read this day-long composed post, I think I solved my own problem.  After about six openings and closings the book cover opens just fine, no image disappearance.  And no "mountain.tiff" icon visible on my desktop.  I hope this tale is helpful to you or other users.

But wait!  That isn't the end of it.  I sail through Preflight Verifier now, it doesn't even pop up, and go directly to the final export Save page. Everything seems fine and so I hit save.  This is what arrives on my desktop (see third screen shot).  The image arrives but no text (compare screen shots).  Please note from the first screen shot the Text Frames are outlined in pale red, sometimes these outlines have been in pale brown before exporting, but I don't what I might have done to cause that or not cause that or if it matters.  If it does matter at one time the frames showed up in the text color (CMYK Orange 3) but no text inside them.  I have no idea what caused that.

The font is Baskerville Regular chosen within Scribus and doesn't seem to have any of the "embedding" issues I've seen via Google.  The Properties palette > text doesn't seem to bark about it in anyway, I can't seem to find any print "lockout" issues, and I have only one layer that everything resides on, the text frames added last.

I'm worn out, can anybody help me on this?


[attachment deleted by admin]


Lots to look at there JohnJR. I'll try to help as best I can.

If you want to export to PDF/X-1a you need to switch Colour Management on via "Document Setup / Colour Management". If you switch this on you will need to use the correct Colour Management settings, otherwise things could look much worse. The correct settings depend on the hardware - monitor and printer - you'll be using and only you and your print shop will know that. If someone tells you to use PDF/X1-a then they need to tell you what printer they're using so you can calibrate your system properly to their kit.

The Preflight Verifier - the dialog that pops up when you choose to export to PDF - doesn't "identify" your export as Postscript. That's just the default setting for this dialog. You need to change the setting to whatever type of export you're trying to make, e.g. PDF/X-1a, or whatever. The setting in this dialog just tells Scribus to check the document against that type of export (because each type of export is slightly different). The PFV doesn't change anything, it just warns about various things that could be wrong. The PFV won't pop up if there are no warnings to give.

Images in a Scribus document - the SLA, not the exported files - are not contained within the document, they are referenced by a relative "link" from the SLA location to the image location. If you move either the SLA or the image then the link will be broken and Scribus won't be able to see that image. You need to re-link the image - Get Image... - to see it again. Scribus doesn't keep track of files being moved around, you need to do that. Best to keep everything related to the same document in the same folder, that way you don't need to move anything. Every time you move something you will have a problem.

If you send something to a print shop you would normally send the PDF and not the SLA as the PDF is print-ready and contains everything the print shop needs to print the document. If you do need to send the SLA to the print shop - or copy it to another machine - then you should use "File -> Collect For Output" which will create a new folder containing the SLA, images, fonts and everything else needed to re-create the document elsewhere (with re-referenced linked images).

The colour of the frame outlines is generally dependant on the settings in "Preferences / Display / Colours" and relates to the "state" of the frame (e.g. linked, etc.).

As for the text going "missing", that's strange. Have you tried a different PDF viewer? Scribus is "targeted" at Acrobat Reader and there are differences between different viewers. Is there any chance you can create a two-page version of the document (take a copy and remove all but the pages shown in your screenshots, then use Collect For Output) and post it here? It's always easier to look at something first-hand.


Hi GarryP, Thanks for responding.

My post did take several days to compose; going back and forth, and my verbose style might have gotten in the way.

I did solve the PDF-x-1a issue using a Googled forum post from 08/08/2012 "Re: How to PDF/X-1a Scribus 1.5?".  I thought just announcing CMYK everywhere and selecting that in the Properties Palette, and in Color Management (CM), would be sufficient, but as per that post, I didn't, as she said, "tick Activate..."  That solved this one before I posted.  Sorry for the confusion.  Just for fun: Ingram/Spark is not a book publisher or even a printer, they are a distributor, in my case a POD distributor (Print On Demand).  They probably contract with perhaps hundreds of printing plants world-wide out of our sight.  Ingram/Spark is one of those monsters that no one ever hears about and asks of us only for the x-1a format and nothing else if you don't want to be dinged $35.

Thanks for the Preflight Verifier (PFV) note and PostScript.  I was sort of fussy in asking and have the neophyte's fear of everything.  Once I "ticked Activate" in CM, Export had no problem as to which flavor of PDF was available.  I made the amateur's intuition that no PFV was good PFV if didn't pop up.

Thanks for the little tutorial about .sla links and X-ed out images.  I does make it clear why Get Image from the desktop worked when I opened up the folder icon then selected (opened) the .tiff image from inside it.  Scribus established a link to the image via the folder.  I did find a clear statement about this when, in the manual, I used the Search option to re-read "Collect for Output" and in the search results there was a separate line item "File Problems" that linked exactly to this image issue.

Since I'm working alone, I originally didn't think Collect for Output applied to me.  When I selected Bookcover.sla (which looked fine and complete to me) and applied Collect for Output, five additional (beautiful) icons showed up on my desktop: two referred to color .icm, two referred to font, one .ttf and the other .ttc, and lastly my good old image, "mountain.tiff".  Let me clarify something that bothered me but I assume is okay: first, one of the color .icm's was sRGB  (not used) when I have only imported and used CMYK.icm; second, I used only one font .ttc which was plain old Baskerville, while .ttf was Arial (not used).  My thought was the sRGB and Arial were originally defaults that Scribus might need internally for some kind of reference.  Should those really be here or are they indications of trouble down the road?

I put all of these new icons and the original Bookcover.sla into their own common folder and named it Collect.  Now what happened I hope doesn't make your heart sink.  I tested the Bookcover.sla but opening it from this Collect folder out popped the old second screen shot (included again herein) without the image.  I tried several things to no avail inside the Collect folder to link them.  I finally dragged Bookcover.sla out of the Collect folder back on my desktop where it sits as its own icon, a sheet of paper with the Scribus logo.  I opened this and my complete book cover returned and looks fine except that all the frames are outlined.  I might ask if all the frame outlines are visible in any color if this means they will print or are somehow not in a good "state"?  P.S.; the frames are not visible in Export, see below.

I experimented with running another Export clear through to Save and nothing changed--no text.  For now I'm leaving the Bookcover.sla independently on my desktop.  So now back to the only problem I thought I had--no text.  The first thing I did was look for what you mean by a "PDF Viewer", oh that.  I discovered that for some reason Adobe Reader, the application, had disappeared from my computer.  Once I downloaded the application again, it opened automatically and the text is there.  There are problems now that I can see it.  All the text is in the wrong font and I bet what we see is the Arial (see above under Collect).  I recognize things like "embedded" from the documentation and for the time being I will see if I can solve that font problem myself.  If you see solutions as to font that are obvious, please could you post them?  Otherwise I'll let you know how I progressed.



I forgot to include my screen shots, sorry.

[attachment deleted by admin]


You'll probably find that Arial is used by your default paragraph/character styles. Even if you don't have anything specifically formatted using those styles, Scribus assumes that you'll be using them. Any formatting you do through the PP overrides the defaults but Scribus still uses the default "in the background". It's odd but can be ignored in most cases as pretty much everyone already has Arial anyway.

You should normally only be using Collect For Output if you need to copy the files to a different machine. If you don't need to copy the files elsewhere then don't use it. All that will happen is that you now have two copies of the same thing. (One exception is: If you want to archive a design then you can Collect everything together in one place. That makes sure that everything you need to re-create it will be available later.) Basically, Collect For Output is something you would only do - if at all - at the very end of your process when no more changes are to be made.

If you don't want the frames to be visible then use menu "View -> Show Frames" to switch them off.

If you have trouble with embedding fonts - some, for example, have copyright restrictions - then use outlining instead. You can see what gets embedded/outlined in the Fonts tab of the Export dialog. You might get a larger or smaller PDF depending on what's being embedded/outlined and how much text is using each font.


Thanks GarryP,

My Problem still remains in Export to PDF-x-1a, the text is likely Arial when it is supposed to be plain vanilla Baskerville.  Every thing is fine in the Properties Palette > Text so I began to ask myself if this is a Scribus issue at all.

I Googled the "extraction" message and found many posts in Adobe forums on just that subject with no satisfactory answers given, some had no text showing at all.  Adobe Reader itself offered no solutions beyond a dim rabbit warren.

Somewhere as an experiment I started fresh and went back to File > Export > PDF, but this time I unchecked PDF-x-1a and selected what seemed the oldest and most generic PDF listed: PDF 1.3.  Guess what, a perfect book cover popped up, Baskerville and all.  The same "extraction" message popped up, I clicked Okay and it disappeared leaving a correct book cover on the screen.  For what its worth, this seems to be a problem with Adobe Reader.

Since my export target requires the PDF-x-1a format, I will take this up with them and let you know what they say.



The issue remaining with PDF-x-1a has gone so far afield from the problems at the beginning of this thread that it seems best to continue to a forum specifically addressing that subject.  If people are having a similar issue with I guess the result of a PDF-x-1a export, they might better locate it there.