Stack overflow error on Windows 10?

Previous topic - Next topic



I work for a commercial printer, and we are looking to use Scribus to replace Quark for some of our internal tasks.
So far, the experience has been positive, but I have run into a problem & am hoping this forum can help.

I have a long list of numbers (400+) in an Excel document which I am copy/pasting into a Scribus document with linked text frames throughout. I immediately get a 'stack overflow' error message and Scribus quits.

Have tried a few things so far: saving my Excel list as a .txt & a .csv and copying form those. I have also tried using the import text function, all with the same results.

Scribus 1.4.6 running on Windows 10, 4GB ram.



for your task, a small python script might be a better solution...

copy pasting the column from your xl file into your .sla file works for me on mac...

no idea if it's something specific to windows (10)...
maybe somebody else can try...


I've just tried to replicate the problem on Win 10 as best I could from my understanding of the description.

NOTE: I don't have Excel so I used LibreOffice Calc instead.

I created a new document in Scribus with two pages. I added five thin text frames to each page and linked them left-to-right then down to the next page.

Then in Calc I typed 1,2,3,4 into the first four cells in the first column, then used the little corner-drag thing - I don't know what it's real name is - to create a vertical list from 1 to 500.

I then dragged a selection over the whole list and copied them to the clipboard.

Then in Scribus I double-clicked in the first frame and pasted the numbers in.

All looks fine. No errors.

I then tried opening the Story Editor, clearing the existing text and pasting the numbers in again.

All looks fine there too.

Sorry, I can't replicate the problem with what I've got.

Are the numbers calculated from something? If Excel is trying to copy the formulae instead of the numbers then that might be where Scribus is having trouble, but that's just a guess.



Thanks for the fast response guys,

I have also tried the same scenario on a mac, Scribus 1.4.6 on OS X 1.9.5 and there is no issue.
Only seems to happen on the Windows work station.

There are no formulas in the Excel file or anything like that, just a simple list of numbers.

If we try using less numbers in the list, it works OK, but as soon as we're pasting in over 250ish numbers, we get the error and crash.

a.l.e., can you elaborate on how a script might be the solution? (I'm a bit of a n00b when it comes to scripting etc...)

GarryP, thanks for testing. Any chance you could try with my files posted to the mailing list? (link in a.l.e.'s post.)



Andy, I tried this:
* in Scribus, created a new document;
* added five tall text frames to the first page;
* duplicated the page;
* linked the frames from left-to-right and down the pages;
* downloaded your ZIP file from the mailing list;
* opened the ZIP;
* In Calc, opened the XLS within the ZIP;
* selected cell A1;
* shift-selected cell A451;
* right-click and Copy;
* back to Scribus and double-click the first text frame;
* CTRL+V to paste.

All looks fine.

I tried pasting the same data into the Story Editor too (after clearing the text) but got the same result - all fine.
I tried selecting a slightly larger area to copy from (A1-A456) just in case there was a problem with the clipboard reporting a different number of items but all was fine there too.
I even tried selecting the whole column and copy/pasting that over without any problem.

Sorry, I'm just not getting the problem that you are getting. Please remember though that I'm using Calc and not Excel. Excel may be doing something different when copying to the clipboard that Scribus can't handle.

I have a sneaky feeling that this problem may come about if Excel is reporting a different number of items copied to the clipboard than are there and Scribus isn't checking that that number is correct - essentially Scribus could be trying to get too many items from the clipboard - but without Excel I can't really test this. (It might be good if you could report the exact version of Excel that you're using.) All this is just a guess though.

One thing that I was curious about was that you said that you got a "Stack Overflow" error message with Scribus quitting immediately. Normally - in my experience - when Scribus crashes it reports a fairly useless "Scribus Crashes. Signal #X" message and then goes into what looks like an infinite loop. Did you get a message specifically saying "Stack Overflow" or did you interpret the signal number? It might be very useful for anyone bug tracking to know this.

The only other thing I can think of at the moment is: Are you using the standard Windows clipboard or are you using a third-party application? If you're using one of those multiple-clipboard apps then that could cause a problem.


Thanks for taking the time to test this out GarryP.

The exact error message I'm getting is: "Scribus crashes due to the following exception: Exception_Stack_Overflow"

We are using Excel 2010, no 3rd party clip board apps or anything like that.

I think our next steps will be to try reverting to an earlier version of Scribus & see if that produces any different results. We have another Windows workstation running Windows 7 with Scribus 1.4.5, and we do not get the same error.



You're welcome Andy.

I'm just sorry that I don't have an answer at the moment. Without the same version of Excel there's no way I can do proper testing.

I've never seen Scribus give an error message like that so it makes me wonder what version you're actually using, rather than what's being reported to you. Can you go to "Help -> About Scribus" and report all of the text under the banner please? You should have something like "Scribus Version 1.4.6 03 January 2016 Build ID: C-*-T-*-C1.8.6-Windows-64bit Using Ghostscript version 9.18".

Also, where did you get Scribus from? Did you download it from the official location - links from the page - or did you get it from somewhere else? (Some people have had trouble in the past when they've been using unofficial versions obtained from elsewhere.)

My only other suggestion at the moment is to copy the range of cells and paste them to a basic text editor (Notepad for example) and then copy the text from the editor and paste that into Scribus. This will "clean" the text removing any weird stuff that might be causing trouble. (It's an extra step but it's worked in the past with a few things.)

I hope someone else reading this can help you more.


The text under the about Scribus banner is:

Scribus 1.4.6
03 January 2016
Build ID: C-*-T-*-C1.8.6-Windows-64bit
Using Ghostscript version 9.06

We downloaded it from the links on the Scribus website.

I did try putting the numbers into a text editor and copy/pasting from that, with no luck.



Thanks for that.

The info' looks fine and if you got Scribus from the official site then you're most probably using the right version.

(You're using a slightly old version of Ghostscript but that shouldn't cause whatever problem you're having. Copy/paste text shouldn't touch Ghostscript.)

My "strange error message" issue was probably a red herring.

I can't understand why just pasting the text from a text editor would cause the same problem. I've just pasted the full text of "Frankenstein, or The Modern Prometheus" (438KB) into a text frame and Scribus didn't complain at all so I can't see how it can be a "size thing".

This is starting to be annoying, but in a good "I want to figure this out" kind of way.

It's odd that you're not having the issue with other copies of the software. Have you tried re-installing Scribus? It might just be some weird hardware/software corruption somewhere. It's easy enough for a single bit on the disk to be toggled and the software still looks like it's working (see, for example, or if you really want some light bedtime reading! ).

It's a shame you're having such trouble with Scribus when you're evaluating it. People coming from commercial software is always good for Scribus so it feels bad when you're having this kind of awkward problem with something that should be straightforward.

I'll let my brain stew on this but, for now, I'm stumped. (Maybe I'm thinking too hard about it and the solution is simple.)


Thanks again GarryP, appreciate all your efforts.
At this point, we are going to try a re-install of the software.

I'll be sure to report back with the results.



Hey guys,

Reporting back:

Did a fresh install of Scribus 1.4.6 and all is well now.
Too bad we could not identify the root cause of this problem, but I'm happy it's working now & that we can continue to use Scribus.

Thanks to everyone here for all the help.



I'm glad all is okay and you can continue using Scribus.

Since you've probably had to overwrite your previous Scribus installation it will probably be impossible to know what the root problem was but as long as you're sorted then that's great. I can try and forget about it now.

Hopefully it was just "one of those things" and you won't have such problems later on.