Font rendering issues with Acrobat on Android

Previous topic - Next topic


Does anybody have any experience with Scribus produced PDFs and opening them on Acrobat for Android? I'm in the process of producing a document but have found that it fails to render the fonts properly on Acrobat on my Android tablet despite working fine with other PDF readers on the tablet and with Acrobat on my Windows 10 laptop. I spoke to the Adobe support team and they think it might be a bug with the way the file is encoded but couldn't provide much help beyond that and I thought I'd check here before I file a bug report. I've attached a couple of screenshots of what the document should look like and how it renders in acrobat, given it's a font issue I also tried a couple of different fonts which didn't appear to make a difference (though I've only tried a small number).

The document was produced with Scribus dev 1.5.2 and the rendering issue is with Adobe Acrobat 16.2 on Android 5.0.2. I've tried a few different PDF versions but ultimately I need it to work with X1a format. I'd like to run the file through the Acrobat Pro tools at some point just to check if that picks up any errors but don't have access to that at the moment and don't know of any other way to dig into it properly.

[attachment deleted by admin]


please share a .sla (collected for output, with the fonts) and a .pdf if you want us to say something...

can you check with MuPDF on android?

personally, i did not even know that there was an acrobat for android...

anyway, it looks like the font is not correctly included... but: who knows?


Oops, sorry should have thought of adding those.

Attached is a quick test document and 2 PDFs. Subsetting the font seems to produce a working file but embedding it doesn't with Acrobat. I've tested both on MuPDF and Xodo on the same tablet and they're both fine with those programs. I'm not really clear on what the difference with subsetting and embedding is but would assume they shouldn't produce such different results.

[attachment deleted by admin]