Problem with PDF embed and Security

Previous topic - Next topic


Hi! New Scribus user here, and already having a big problem with PDF exporting. I need to create fillable PDF forms with a password to protect them from editing, all based on older, non-fillable PDF forms originally made just for printing.

What I'm doing: I embed an old document on the background in an image frame and build a form (just some check boxes, text fields & javascript) on it. Until this point everything works perfectly and I can generate a working PDF form, but then I meet a problem: if I try to export it with any security options enabled the embedded PDF disappears, leaving just the form elements floating on a white background. No matter if I check the "Embed PDF & EPS files (experimental)" (which I would need anyway though) or not, I can't get Scribus to export my document correctly with security enabled.

Somewhat related, I'm exporting on PDF 1.3 because I can't get text fields to accept input on 1.4 or 1.5. Switching to newer PDF version doesn't help with the above major problem with security, but I would be glad if someone happened to know a solution to this, too.

System: Windows 10, Scribus 1.5.2.

Any ideas? We'll have to move back to Acrobat Pro if I can't resolve this somehow. :(

[attachment deleted by admin]


I don't know for sure, but one problem may be that PDF 1.3 does not support transparency. But if you get the same problem also with PDF 1.4 and up it must be something else.

Without sample files showing the behavior it is hard to figure the problem out.


Sorry for not including test file immediately. The files I'm working with are confidential but I threw together a quick demo file that has the same problem. It also throws some errors about being unable to draw or to use embedded font, which have somewhat erratically appeared with the real files, too. I also double-checked once more just to be sure and the problem appears even with PDF 1.5, so it's probably not transparency.

Edit: Oh, and the demo file password is password

And thank you for looking at this. :)

[attachment deleted by admin]



I am using scribus 1.4.6 on Lubuntu 16.04 to create an encrypted pdf file.  I am using adobe reader 

In scribus I have created javascripts that create most of the details of my 9 page pdf document form.  The javascripts all work perfectly when I do not use a password.  When I use an owner password with allow changing the document and allow copying text and graphics, I get the following error when I open the document in adobe reader: "SyntaxError: syntax error 1:Doc:open.  I've tried with a few different options, user encryption, owner encryption, . . ., but I always get an error and my javascript does not run.  I have javascript that is supposed to run when the document is opened - that is the javascript that creates all the elements of the form.

When I remove the password, everything works again.

I have tried compatability with pdf 1.4 and pdf 1.5

Would someone please explain this.

I have attached my scribus file, as well as different versions of the pdf (with respect to how passwords are applied).

I thank all in advance for any help you can provide.


[attachment deleted by admin]