pdf won't print

Previous topic - Next topic


First time on the forums and I've used scribus on and off for years and love it.  I downloaded a CV template from here  http://www.partlycloudy.org/scribus/resume/2010/09/30/scribus-resume.html.  I've adapted using largely the Andika font.  The problem is it won't print from pdf from acrobat or anything else.  It starts printing and then stops having printed a bit.  Then the printer cancels the print job something I've never had happen before.  Okular does print it but incorrectly.  I've filled a block of text with grey colour to highlight it.  Okular prints this in yellow rather than grey.

Any clues? it needs to print from acrobat for obvious reasons.



Welcome to the forum Neil.

Personally I wouldn't use a template for a CV. There's so much text that you need to add that the extra work taken to add your own text frames into a blank document fades into insignificance.

As for the problem you're having, it could be almost anything:
* Does a change in font make a difference? It could be a dodgy font.
* The template could be designed badly. Are there any layers containing stuff you don't know what it's for? Are there any frames or objects that don't have a reason to be there?
* Does the text contain any unusual character strings? They might be hidden if you've copied and pasted from a file that isn't plain text.
* Your printer driver could be faulty. Do you have the correct and up-to-date version?
* Have you got the latest version of Acrobat?
* Are you using a stable version of Scribus? 1.4.6 is the current recommended version.

Normally I'd ask for you to attach the document with the problem in it but as it's your CV - containing all sorts of personal information - that's probably not a good thing to do.


I think printer out of memory could be something too, if the font is large and gets downloaded to the printer.


Thanks for your reply GarryP.  I've got off to a great start here.  I forgot to say I was using 1.4.2 in linux mint 17.3.  Forgot to say the following.  Also I tried taking the text background fill out. Made no difference as does embedding the fonts.  I think it must be the template.  It prints a bit of both fonts used then halts.  I did my own similar design from scratch which prints although the grey background fill is missing printing from acrobat, although this is livable with.  I will try making my own similar design from scratch with the same fonts for the second CV when I have time in the meanwhile the other design is usable.

Ta.  Neil


Yes could be that it gets as large as 23k when printing from atril then stops, 256K from acrobat stops and 63,000K from okular but has printed from this program.  The pdf is not very big though.


I cannot say I have solved this but I have found a way round it.  I tried upgrading to 1.4.6 no joy.  Tried changing fonts but getting rid of all traces of the font are difficult to do even if you are not using it. Made no difference.  I tried printing from the template I imported - fine.  I thought the page->manage page properties may be the solution.  In document setup this was set to A4 in page->manage page properties it was letter.  From what has printed it was printing the right hand margin too far to the right.  I don't know why there are two ways of setting the page size which seem to contradict, but it it did not help.

My solution is to export in SVG format open it in inkscape and print to pdf using the CUPS printer.  This gives me less control but works apart from the block of grey is appearing as yellow.  Is it possible to force scribus in greyscale?


Proabably something to do with embedded fonts not allowing pdf creation as I have just found out elsewhere on these forums...


Something that can sometimes be confusing is that Scribus allows you to use a different page size for every page. So the settings in Document setup will only affect newly created pages, not already present pages.


Point taken but page is A4 which is what we use.