Scribus > Text and Typography

Strange characters with Adobe Reader X

(1/2) > >>

Merton:
Hi all,

      I've been a Scribus user for about a year now, but am having an issue with reading PDFs in Adobe Reader X (the latest version at this time).  I have a PDF with text frames and form fields (text fields and a push button), but the text of the form fields displays as weird characters.  It's almost as if there is a problem in the character set.

      I noticed this problem while using Scribus 1.3.3.13 and upgraded to 1.4.0.rc5, but this didn't help.  The PDF opens perfectly in Adobe 9 (I had Adobe v9.4.5 before upgrading), but not in Adobe X (v10.1.0).  There is no such problem in a PDF made in Adobe Acrobat Pro using both Adobe Reader 9 and X, so it's only the PDFs I've made in Scribus, and only with Adobe Reader X.  I'm running the latest version of Scribus and GhostScript v9.02 on Windows 7, though the same problem occurs on Windows Vista systems.  Additionally, I'm not using any crazy or rare fonts: the PDF fields use Verdana, though I have tried the standard Times New Roman as well.

I've also noticed a few differences between the PDFs made in Scribus and Adobe Acrobat Pro which may account for this, but I have no idea.  My Scribus PDF says it's not a "Tagged PDF," has a lower "PDF Version" than the Adobe PDF (1.4 compared with 1.7), and has "Page Extraction" allowed.  I'm getting these options by clicking "File -> Properties" in Adobe Reader X and not sure if they actually contribute to my problem, I just figured more information couldn't hurt.

Has anyone else had this problem?  Any suggestions for a solution?  Much thanks!

Meho R.:
An example SLA file (as well as its PDF output) would be useful. Have you tried saving the document as PDF 1.5 and use default "Helvetica" for text?

Merton:
Thanks for the quick response!  I had originally used the PDF 1.4 Compatibility, but I have tried PDF 1.5 with no improvement.  And, as you'll now be able to see, the text fields within my PDF do default to Helvetica, though I have tried both Times and Courier.

PDF:
http://www.mertonslair.com/tmp/employment_application.pdf

SLA:
http://www.mertonslair.com/tmp/employment_application.sla

Meho R.:
Hmmm, right. Actually, Adobe Reader X is the only reader that has this problem. I tested with a bunch of other PDF readers, no problems at all. Probably it's better to ask at Scribus mailing list, maybe devs can explain this.

Merton:
Just an FYI, I've submitted this as a bug and am waiting for the developers to evaluate and/or fix it.  I will post again when this is resolved, for those of you who are experiencing the same issue.

http://bugs.scribus.net/view.php?id=10079

Navigation

[0] Message Index

[#] Next page

Go to full version