Scribus doesn't recognize greyscale png, thinks they're RGB

Previous topic - Next topic


I have a logo that I need to place on the title page of a book. I created it in Inkscape and am preparing it for print in Gimp. It is black with a transparent background. In Gimp it is saved as a grayscale png image. When I import it to Scribus (1.4.1), image info reports the colorspace as RGB. For a black and white interior, my printer requires all images be grayscale. I'm not sure what else to do to get Scribus to recognize the image for what it is, grayscale. Suggestions?


4 Solutions:
1. Embeded in Your bitmap gray icc profile (in Krita, or Photoshop, or in imagemagick etc.) Scribus can see this icc.

2. Turn off color management before publish pdf

3. Use Image effects -> Greyscale (and before publish to pdf turn off color management)

4. If You use only one black color, use greyscale mode in publish to pdf window. (available from output intent for)


here there is icc profile - ISOcoated_v2_grey1c_bas.ICC (4 KB)


Leaf, thank you so much! So glad to know there's a solution.