Scribus 1.4.3 crash on startup (Win7 64 bit)

Previous topic - Next topic


I installed Scribus (scribus-1.4.3-windows-x64.exe) on my computer. When I run it, the splash screen comes up and it searches for fonts but then goes away.

I ran Scribus with the following command line: Scribus.exe" --console --font-info
The console data flies by very quickly but I see it processing fonts and then a message flashes for a fraction of a second before the console window goes away. The message looks like: Syntax Error: Invalid Syntax

I have tried uninstalling, reinstalling the 64 bit version with the same results.
I uninstalled the 64 bit version and installed the 32 bit version (scribus-1.4.3-windows32) with the same results.

Any suggestions?


I don't use Windows 7 myself but it sounds like you might have a font that Scribus can't handle for some reason. Not all fonts are well behaved.

If you don't have lots of fonts you could try disabling a bunch of them, then trying Scribus again, then if you get the same problem disabling another bunch and re-trying etc. etc. Once Scribus starts properly you can then start re-enabling the last bunch of fonts disabled - one by one - until Scribus doesn't start up. The last font re-enabled will be the dodgy one. Delete it - as long as it's not an important one - and re-enable the rest of your fonts. (If it is an important one then I don't know what you can do.)

It's not a great solution and might take some time - and might not even show where the problem is in the end - but it may be worth a shot.

Alternatively, you could try booting in "safe mode" (PF8 or something? I can't remember.) and seeing if Scribus works but I'm not sure how safe mode handles fonts so that's probably a long shot and still won't tell you which font is causing the problem, if indeed it is a font that is the problem.

Sorry I can't be of more help but I hope this goes a little way to solving your problem.


Thank you for your help. It sounds like a good strategy.


Scribus crashed on startup in safe mode. Deleting fonts didn't prevent the startup crash. Any other ideas are welcome.


I figured out how to capture a screen video so I can get the error message. It seems to load all of the fonts correctly but then give the following message:
  File "C:\Python33\Lib\", line 173
SyntaxError: invalid syntax

I use both Python33 and Python27 and so both are in the PATH. I am assuming it wants to use Python27. How do I make that happen?



Same issue with Win 7 (Splash screen, then nothing). Did you manage to find a solution ?


My solution was brute force. I created a BAt file that renamed the Python33 folder to Python33-, then started scribus, then reset the name of the Python33 folder after I exited Scribus.


Nice ! It worked for me too. Weird, but efficient.