Scribus > Installation and Setup

Compiling Scribus with Qt 5

(1/1)

a.l.e:
Sometimes last fall, the Scribus team switched to Qt 5.

Since the support for it was still very flacky, you were required to get the compiled tar ball from the Qt project.

The distributions have slowly been adopting Qt 5 and Debian testing now provides all the packages need to compile Scribus.

On top of the packages pulled in by apt-get build-dep you need.

- `libqt5webkit5-dev`
- ` qtquick1-5-dev`
- `qtdeclarative5-dev`
- `qttools5-dev-tools`
- `qttools5-dev`
- ` liblcms2-dev`

This should also apply to the newest Ubuntu, too.

There is probably little chance to get it into Debian stable... but you're not really supposed to use Debian stable for the Desktop either...

Have fun!
a.l.e

Navigation

[0] Message Index

Go to full version