Inserting objects leads to empty Line Style and produces random crashes

Previous topic - Next topic



After inserting some of my objects from scrapbook, Scribus creates a new empty Line Style with 0.00 pt line width (pic1) and adds this tag in the sla-file:
<MultiLine Name=""/>

I cannot find out which objects cause this behaviour. In the attached file for example, it is a simple text frame with own Paragraph Style.

From this moment scribus tends to random crashes.
I can also provoke a crash by trying to edit this style:

Trying to change "Line Width" from 0.00 pt to 1.00 pt --> crash (pic2)

Console output:
Scribus Crash
Scribus crashes due to Signal #11
Calling Emergency Save
memory access error

Can anyone help me with this issue or is it a bug?

Scribus-Version: 1.4.3
20 Juli 2013
Build ID: C-C-T-F-C1.12.16
Ghostscript-Version: 9.10

OS: Archlinux
QT version: 4.8.5


[attachment deleted by admin]


CiTa, I have some questions which, if answered, may help someone diagnose your issue a little better.

1. How are you inserting objects from the scrapbook? Are you dragging them to the page or using the "Paste to Page" function.
2. Why can't you tell which objects are causing this behaviour? Are the objects you are inserting grouped so you don't know which one is the problem? Or is it that you don't have enough "test subjects" to determine which kind of object is causing the problem most often?
3. Have you tried deleting the errant line style instead of modifying it? (That seemed to work when I tried it on your example but it obviously doesn't fix the actual problem. I tried editing the style and got a Signal #6 crash, so that's a different error to that which you reported.)

I tried replicating your issue - creating a text frame; giving the text a paragraph style; sending the frame to the scrapbook; rebooting Scribus; dragging the frame from the scrapbook - but I didn't get the same problems as you. (I'm using 1.4.3 on OSX, whether that matters or not.) I did however notice some odd behaviour with the styles list but this may be unrelated, and it didn't cause a crash.

I hope you get an easy answer to your problem but, personally, I don't use the scrapbook much as I've had various problems with it in the past. Unfortunately they're often difficult to replicate so reporting issues is difficult.


Hi Garry,
thanks a lot for your detailed reply!

I don't know yet, which item caused this problem - perhaps it was an imported and ungrouped SVG. But I could solve the problem for now. I will describe it, perhaps it may help someone else.

Some time Scribus must have added this blank line style in one of my projects, perhaps during editing an imported SVG...
Responsible for this style is the following tag in the SLA file:
Quote<MultiLine Name=""/>

When I insert an object (eg a Textframe) into the scrapbook from a document with this blank line style, Scribus also copied the Tag <MultiLine Name=""/> into the corresponding SCE file. Now when I insert this object from the scrapbook into a new document, scribus importes the blank line style as a style of the object in this file, and so on. Clear? I know it seems crazy, but it's true!  ;)

My solution:
I searched all my SLA and SCE files and removed the Tag above, wherever I found it, manually.
From this time on the "ghost style" has disappeared! Happy Halloween!?   :D