Scribus > Vector graphics and postscript

Preflight verifier flags SVG images

(1/2) > >>

Hello all:

I am using Scribus 1.4.3. on Lubuntu Linux 13.10. I have scoured the net trying to find anything related this topic, with no success so far. Let's say I:

1. import a bitmap image into Inkscape;
2. produce an svg file by tracing it in Inkscape;
3. create a document in Scribus;
4. import the svg file into the new document;
4. call the Preflight Verifier.

Oftentimes the Preflight Verifier will warn me that the file has less than 144 dpi. Reducing the svg frame size within Scribus will eventually suppress the warning; enlarging it will eventually cause the warning to be issued. This apparently does not happen with svg files that have been created directly with Inkscape. I find this puzzling, because an svg file should not cause dpi problems, unless a bitmap image has been embedded into it - which is not the case, as far as I know, because tracing has been used.

An example is shown in the attachments. The original bitmap file was an jpg, which was cleaned, sharpened and exported as princeto.png, by means of Gimp 2.8. This was then imported into Inkscape 0.48, traced with the Color option on and Smooth option off and the remaining options at their default values. This svg will produce the low-dpi warning described above. Reducing the heigh and width of the svg-frame simultaneously will eventually suppress the warning.

I wonder whether I should really pay any attention to this when preparing pdf files for printing. If so, what would be the solution?

Thank you for your help.

Francisco S. Wechsler


hi francisco

your uploaded .svg file doesn't contain any vectors. there's only a .jpg compressed pixel graphic – at least as far as i can see…
how did you try to vectorize it?


Hi, Utnik.

Maybe what you see is a png graphic, because I tried to vectorize the attached png file. Anyway, here's the vectorization process I used in Inkscape, step by step:

1. File => Open => Choose the png file.
2. Mark "Embed image" => OK
3. Mark the image by clicking on it.
4. Path => Trace bitmap
5. In the Mode tab of the trace window mark: Colors & Stack scans  and unmark Smooth. Also enter "8" for Scans
6. In the Options tab of the trace window: Suppress speckles (size=2); Smooth corners (threshold = 1.00); and Optimize paths (tolerance = 0.20).
7. Click OK. After the tracing process has been completed, close the window.
8. Press END.
9. Press DEL (delete bitmap image).
10. File => Save as => Enter name => Choose Inkscape SVG => Save.
(Choosing Plain SVG won't make any difference for Scribus.)

Hope this is clear enough. Maybe I have missed something? Actually you may try it yourself, using the attached png file.


Francisco S. Wechsler

Hi, Utnik:

You're right. For some reason I uploaded an svg file with an embedded bitmap. Sorry about this.

Please take a look at princetoB.svg. I magnified it considerably, and I could not detect any dot patterns, only lines were visible. And yet this very file caused the same problem with the Preflight Verifier.

Thanks again.

Francisco S. Wechsler

hi francisco

the princtoB.svg contains both, the original image and the vectorized version of it.
you don't see the pixels, because the image lies below the vectors. but in the xml-editor you can see (and select) it.if you delete this pixel image, the 'less than 144 dpi' warning won't appear any more.



[0] Message Index

[#] Next page

Go to full version