.svg in image frame – strange answer in mantis bug tracker

Previous topic - Next topic


in scribus 1.4.2 it was possible to load .svg files in image frames ('files of type' → 'all files(*)' in the 'open' window...) in 1.4.3 this doesn't work any more.
i mentioned this as a bug and was told that it wasn't possible in any existing scribus version. as i recieved a .sla file produced in 1.4.2 on windows xp and wasn't able to display or export it correctly, i reinstalled 1.4.2 on mac os. with this version it worked – and i was able to load any other .svg file in an image frame and export it to .pdf.
even when i uploaded a file (see bug #11698), instead of trying to open it in 1.4.2, one of the developers told me, that what i uploaded doesn't exist...
for me, this is a very strange behavior.

  • if you receive .sla files with linked .svg files in a frames, you will be able to open them in scribus 1.4.2
  • i you're still working with scribus 1.4.2, avo inserting .svg files in frames or be aware that this feature doesn't exist officially and expires with the next update!


salü utnik,

i've never heard about this feature either... and i wonder why it works...

i've just created an svg in inkscape and i could indeed load it in an image frame in scribus 1.4.1. (os x)

i wonder if it's a specific version of ghostscript that is allowing this... or some other library?

all in all: it's a very old request of mine to have vector drawing in frames... but there is no real interest in going for it :-(



hi ale

thanks for testing!
i run scribus 1.4.2 and 1.4.3 with the same ghostscript 8.64 – in 1.4.2 this .svg in frame thing works, in 1.4.3 it doesn't – not ghostscript version related...
by a closer look, i recognized that it's not a vector graphic any more. the .svg gets rendered when i place it in the frame. (i saw this in your info box and double checked with my file...) in this case it's rather a bug than a feature.