Help finding path to ghostscript

Previous topic - Next topic


Hi all,

I just installed Scribus 1.4.2 on my mac running OSX 10.6.8
Scribus asks me to install ghostscript

I downloaded ghostscript 9.07, unpacked it and draged the folder in library/frameworks

I reinstalled scribus and nothing

I tried to find the path to the mysterious «gs executable file» via the external tool of scribus preferences, but I am reaching my limits here

can anyone let me know where is the file i should use withing the ghostscript 9.07 package ?

Thanks a lots


Valerian, I've never installed Ghostscript the way you've described.

A PKG, DMG, or Macports is the usual way to install stuff on Macs. Manually unpacking and dragging it sounds odd to me but it's not for me to say that wasn't right for you, it's just not what I would have recommended is all.

Anyway, you can try this:

Go to Terminal and type
find / -type l -name gs -print
The process will take a few minutes and you'll probably get some "permission denied" messages (unless you're set-up as a super user or use the sudo prefix) but somewhere in the output you should see a path, such as
(Once you've spotted a path you can CTRL+Z to stop the search as it just ploughs on through all of your connected drives.)
Copy this path into the "External Tools / Postscript Interpreter / Name of Executable" box of the "Preferences" dialog and press OK.

You might have to restart Scribus.

If that doesn't work I would suggest looking for a DMG or PKG which will install Ghostscript "normally".


I seem to have the same problem as Valerian, except I downloaded Ghostscript 7.07.1 (espgs-7.07.1-source.tar.gz), as I found somewhere that this was the latest Ghostscript version compatible with Snow Leopard (10.6.8). Apparently, it does not suffice to donwload and expand that .tar.gz, it would also need compiling or something... I tried to follow the instructions in the README that comes with the package, but to no avail. Please, can someone help me fix that ? I'd really like to be able to use Scribus to its fullest !



I finally found a way that works ! (Scribus error messages weren't very helpful, since they redirected to outdated sites...) So, here's where I found a link that worked to properly install Ghostscript, it's on : — what worked for me was the link under Ghostscript DMGs. Have a good day !