Scribusoid

Author Topic: Problem with default font not being used  (Read 1860 times)

chichirodriguez

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
  • Scribus User
Problem with default font not being used
« on: March 23, 2013, 01:44:36 am »
Hi, I've been using Scribus for a couple of days now and cannot figure out how to get text boxes to use the correct font when I create a new box.  I have the font set to, for example, Arial, in both my Document Setup and also in the generic Preferences dialog.  But, when I go to type in a newly created text box the font generated is, for example, Times New Roman.  When I began my document I was using Times New Roman, but decided I didn't like it so I changed everything to Arial, but I can never get Arial font unless I type something out, highlight the text, and manually change the font to Arial.

I've shut down Scribus and restarted it, but the problem still occurs when ever I make a new text box.

Perhaps even stranger to me is that when I go back to edit an existing text box and change even a single letter it will appear in Times New Roman font even though everything in that box was originally Arial.

Help!  I'm ready to start punching the wall over this!

Nermander

  • Hero Member
  • *****
  • Posts: 1311
  • Karma: 17
Re: Problem with default font not being used
« Reply #1 on: March 23, 2013, 10:20:48 am »
The Default font thing is Scribus is a little confusing...

You have to set the default font also for the text frame tool in the setup.

I'd say the best way to avoid the problem is to not use the default font. Create styles. Set a default style for text frames. Then you just have to change that style to change all the text.

I don't think changing the default font will change the text already present in the document...

 

palmate