Author Topic: How do i fix Broken Packages ??  (Read 3271 times)

dduran1210

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
  • Scribus User
How do i fix Broken Packages ??
« on: January 22, 2013, 07:14:15 pm »
Hello, Newbie at this.  I am trying to install Scribus in LinuxMint 14 via the Synaptic Manager.

when I try to apply Scribus, I get this message:

"could not apply changes! Fix broken packages first."

I'm like WHAT broken packages???  I tried to remove Scribus in terminal...but says: no scribus installed...  geez.

$ sudo apt-get install scribus
[sudo] password for dave:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 scribus : Depends: libhunspell-1.2-0 (>= 1.2.11) but it is not installable
           Depends: libpython2.6 (>= 2.6) but it is not installable
E: Unable to correct problems, you have held broken packages.
 

can someone help ??

thanks
« Last Edit: January 22, 2013, 09:16:25 pm by dduran1210 »

Nermander

  • Hero Member
  • *****
  • Posts: 1311
  • Karma: 17
Re: How do i fix Broken Packages ??
« Reply #1 on: January 23, 2013, 08:26:45 am »
The error message says that Scribus can not be installed because some of the libraries Scribus depends on are not installable. Why they are not installable I don't know, I think the last row means that the are manually marked as Hold (which means "do not upgrade"). If you have done this by accident or on purpose I don't know.

I'd say the error has nothing to do with Scribus, it's a common "dependency problem".