Author Topic: missing glyphs  (Read 2399 times)

jack_cat

  • Jr. Member
  • **
  • Posts: 56
  • Karma: 0
  • Scribus User
Re: missing glyphs
« Reply #15 on: July 24, 2019, 07:56:49 pm »
I'm trying to use characters from the font "Noto Music Regular".  ....a missing glyph....
-DZ

Having run into similar problems, I have a cludge of a work-around:
Use Inkscape to make a graphic file of the glyph, put that graphic in an image box in Scribus,
and paste it over the finished text where you have left an appropriate space,
then group the text box and the glyph and don't edit the text any more.
I have a folder full of miscellaneous musical symbols. I can paste them on top of
text or on top of imported staff notation graphics.
Sorry I wasn't timely with this reply, I only visit when I have a problem!
jack

jack_cat

  • Jr. Member
  • **
  • Posts: 56
  • Karma: 0
  • Scribus User
Re: missing glyphs
« Reply #16 on: July 25, 2019, 06:16:35 pm »
I add one more point that may be relevant to this problem:

I have one not-so-unusual glyph I use regularly, a musical "natural" sign which I take from the font "Times Scale Degrees". When I am using the Story Editor, if I try to use this character with "Insert > Glyph", a forward slash is inserted instead. In order to make this symbol show correctly, I have to edit the text directly in the text frame; then when I use "Insert > Glyph" the symbol shows correctly. If I then re-edit in Story Editor, it may disappear and become a forward slash again, and then I have to re-select it in the text frame and insert it again. This is the only glyph I use that behaves this way; other glyphs taken from a variety of fonts show correctly without issue. When I edit text in the Story Editor now, I just write, e.g. "B-nat" and then replace the -nat with the glyph after exiting the Story Editor.

Therefore, if having difficulty getting a glyph to display correctly as in the problem described by the OP, it may be useful to try it both in Story Editor and in the text frame, and see if one or the other works to display it correctly. 

If I were unable to get it to show correctly at all, then I would make a graphic out of it and insert it as an image, as noted in my previous post. For use in a passage of text, of course, this is very inconvenient and is a last resort.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2176
  • Karma: 28
    • the graphics lab
Re: missing glyphs
« Reply #17 on: July 25, 2019, 07:25:46 pm »
i had a bit of issues with following the full description... so a question from my side:

if you only use the in text frame, does it work correctly?

ciao
a.l.e

jack_cat

  • Jr. Member
  • **
  • Posts: 56
  • Karma: 0
  • Scribus User
Re: missing glyphs
« Reply #18 on: July 25, 2019, 08:46:49 pm »
Yes, when I insert the natural sign from the Times Scale Degrees font directly into the text frame using "Insert > Glyph", it displays correctly and also exports to PDF correctly. I am perfectly happy with the way this works.

However, if I edit the text frame in the Story Editor and change the Style of the paragraph containing the inserted natural-sign glyph, the glyph will revert to the forward slash which occupies that position in other fonts.

I don't consider this a problem, since I have a working solution, and I just change it back in the text frame. I am always all in favor of the workaround that works the quickest. From the POV of you all, the intrepid programmers, this may be a problem in the Scribus code; to me, it's a problem solved.

I suggest that the OP might try inserting the problem "down-bow" glyph of the original post directly into the text frame instead of using the Story Editor, as a simple test, before seeking more elaborate solutions. It would be perfectly reasonable to do most of the editing in Story Editor as usual, and only add the glyph afterwards directly into the text frame when everything else is in order. If it works, great. If not, ehhh, on to the next idea.

Since the OP insists that other programs use the font, and since he or she clearly said that the problem occurred when using the Story Editor, I think that my experience with the natural-sign glyph also not showing correctly when inserted in the Story Editor, might be relevant and might provide a solution which will work even if it does not solve the issue on a programming level.

As a musician, I observe that there have been various issues that have arisen between Scribus and music notation programs in general, since staff notation is a specialized non-text symbolic language which in my experience is best treated in Scribus with imported image files. There are a lot of fonts that attempt to make musical symbols into text, and some are better than others. "Lilypond Book" is the program that, ideally, totally bridges that gap, but Scribus regardless of its faults is infinitely easier to learn to use than Lilypond.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2176
  • Karma: 28
    • the graphics lab
Re: missing glyphs
« Reply #19 on: July 26, 2019, 11:29:24 am »
all i can say: try to do as much of you editing in the frame and avoid the story editor except for the cases where it's really useful.

the story editor is not state of the art and, nowadays, should be avoided.

 

palmate