Author Topic: Solved mailto: links on exported pdf not working  (Read 5243 times)

Downunder Dabbler

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Solved mailto: links on exported pdf not working
« on: July 25, 2015, 05:33:47 am »
:-\Another newbie joins the fold ... and stumbles ... or perhaps it is just a hiccup ...

Using Scribus 1.4.5 on Win 7 and am very happy as I slowly climb the learning curve. Have produced a pdf doc advertising an event later this year and all is well until I try to add mailto:email@address

Have added 2 links to external website addresses as pdf annotations and they work as expected.

Have added 2 mailto: links that don't work. Adobe reader does nothing when the link is clicked and Evince pops up an error message, "Unable to open external link. Error stating file 'C:\Users\Owner\Desktop\Devi Sydney\MAILTO:address@gmail.com': No such file or directory"

When I used lower case mailto: the error message was " ... Error stating file 'C:\Users\Owner\mailto:address@gmail.com': No such file or directory"

There is a second email address that is not gmail and it does not work either and gives the same message.

Both mailto: addresses are in an external weblink annotation text box.

What have I missed here?

With thanks from downunder ...
« Last Edit: July 27, 2015, 02:02:18 am by Downunder Dabbler »

Nermander

  • Hero Member
  • *****
  • Posts: 1305
  • Karma: 17
Re: mailto: links on exported pdf not working
« Reply #1 on: July 25, 2015, 08:02:55 pm »
Here's an older topic where it seemed to work as expected.
http://forums.scribus.net/index.php?topic=456.0


Downunder Dabbler

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: mailto: links on exported pdf not working
« Reply #2 on: July 26, 2015, 02:35:08 am »
Thank you but that is not useful - I read that before posting my question as well as searching for others.

As far as I am aware I have followed all steps to the letter that are described in the scribus manual accessed via the help menu on 4.1.5

As well as not working on my flyer, I created a new document;
inserted a text frame containing "mailto test";
inserted a link annotation via the feet symbol on the toolbar;
selected the External web-link option and entered mailto:myemailaddress;
saved the document;
exported to pdf 1.5;
opened pdf and clicked on mailto link;
read message, "Error stating file 'C:\Users\Owner\mailto:hakimoerton@gmail.com': No such file or directory"

It appears Scribus is looking for a file, not an external web link.

The end result is the same for the 1.3, 1.4 or 1.5 pdf export options.

Any ideas please? I would just file a bug report but it seems that this version has been around for quite a while and there are no other reports of this behaviour that I could find.

With thanks from Downunder



Nermander

  • Hero Member
  • *****
  • Posts: 1305
  • Karma: 17
Re: mailto: links on exported pdf not working
« Reply #3 on: July 26, 2015, 05:52:52 pm »
As I wrote in that topic (I think): It is not Scribus that is executing the link, it is the PDF viewer.

Scribus just creates the PDF, everything after that is done by the PDF viewer.

Downunder Dabbler

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: mailto: links on exported pdf not working
« Reply #4 on: July 27, 2015, 02:00:14 am »
What you say Nermander is very relevant and I think I am expecting too much from a PDF. I will mark this as solved and look at alternative ways of achieving what I want.

Thanks for your patient input.

 

palmate