Scribus Forums

Scribus => General Discussion => Topic started by: IDN101 on May 02, 2018, 07:14:30 pm

Title: Disable keyboard shortcuts when typing in text frame?
Post by: IDN101 on May 02, 2018, 07:14:30 pm
I have played around setting some new keyboard shortcuts- I'm left handed and use the mouse in the right hand. So putting al the zoom to fit, properties, scrapbook on the left hand side of the keyboard.

If I create a shortcut:       1

Then when I'm typing in a text frame and I need to actually use the character 1, it activates my shortcut and cancels the editing of the frame.

So I try SHIFT + 1, which is "!"- bt again there will be times when i need to use "!".

Can I disable the detection of shortcuts when I am editing a text frame directly?

Thanks
Title: Re: Disable keyboard shortcuts when typing in text frame?
Post by: a.l.e on May 02, 2018, 07:21:11 pm
no you can't, otherwise you cannot copy paste anymore : - )

currently, there is no way to have user defined shortcuts without a modifier.

but we're open to pull requests :  - )
Title: Re: Disable keyboard shortcuts when typing in text frame?
Post by: IDN101 on May 02, 2018, 07:24:42 pm
Many thanks,

I guess it's not the end of the world to activate the Story Editor when I need to add one of those characters that is assigned to a KB shortcut. Most of the time I'm copying and pasting text in from somewhere else.

I think I'll stick with   1   (without a modifier) for "Zoom to Fit height"

Thanks
Title: Re: Disable keyboard shortcuts when typing in text frame?
Post by: a.l.e on May 02, 2018, 08:51:36 pm
"insert > glyph" is your friend.

you can "bookmark" the character that you use more often.

personally, i don't like and i plan to create an alternative tool for inserting characters. but i have to finish some other work first.

but i also need a good way to insert an n-dash...