Scribus Forums

Scribus => Text and Typography => Topic started by: itsajungle on August 11, 2016, 04:09:17 pm

Title: Text splitting after image
Post by: itsajungle on August 11, 2016, 04:09:17 pm
Hi,
This is a weird one! In Scribus 1.5 I've got a load of text; when I include an image, and have the text flow around the image, the text is only including a few characters on the line below, before starting a new line. This doesn't happen if I remove the image (see two screen shots). Any ideas why this is happening, and what I can do to solve it? In the first, the word "Rapidement" has been split after the letter p, if I remove the image (second screen shot) it's fine.

Thanks!
Title: Re: Text splitting after image
Post by: Nermander on August 12, 2016, 08:29:09 pm
This looks very similar to something recently discussed (I don't know if it was here or the mailing list), if I recall correct this is a problem with the first line offset of the frame.
Title: Re: Text splitting after image
Post by: itsajungle on August 12, 2016, 08:56:04 pm
Thanks. Any ideas as to how to go about fixing it?
Title: Re: Text splitting after image
Post by: Nermander on August 12, 2016, 11:30:33 pm
Try changing the first line offset?

You can choose between:
Maximum Ascent
Font Ascent
Line Spacing
Baseline Grid

It seems as if Maximum Ascent is the default, I'm not sure that is the best default. Most users would probably expect Line Spacing or Baseline Grid.

Title: Re: Text splitting after image
Post by: itsajungle on August 13, 2016, 12:22:47 pm
Brilliant, that did it! Thanks for the help.

It looks like I can only change this frame by frame, am I right?

A
Title: Re: Text splitting after image
Post by: Nermander on August 13, 2016, 01:18:39 pm
Yes, there is a bug report for that (found it when I tried to google for info on the issue), there were discussions if this should be part of the paragraph style or if it should wait until we get frame styles.

Not sure if a default can be set in the document preferences.