Scribus Forums

Scribus => PDF Generation => Topic started by: Kyle Willey on April 10, 2012, 06:06:24 pm

Title: Form Fillable gibberish
Post by: Kyle Willey on April 10, 2012, 06:06:24 pm
I've been having a problem; I'm writing a tabletop game for Game Chef, and I finally got my form fill text boxes to work. Problem is rather than actually filling with what I type, they fill with random characters. Any clue why this is?

In addition to these random characters, I seem to be getting a "font-not-found" square placeholder. Any clues what's going on here?

Attached is the box, and my .sla file as is.

Any fix is appreciated; the game itself is finished and I hope to have the character sheet done in no more than 30 hours.
Title: Re: Form Fillable gibberish
Post by: Kyle Willey on April 10, 2012, 06:08:56 pm
Solved my own problem by switching to PDF 1.3 format, but I think this is just a workaround.

If possible, I'd like to embed a custom font, and I think the reason it works in 1.3 is that it's using a default one in the Adobe software.
Title: Re: Form Fillable gibberish
Post by: Nermander on April 11, 2012, 09:37:07 am
The most important piece of information is missing: What PDF Viewer do you use?

As far as I understand the limitation on whether embedded fonts works in form fields or not lies in the PDF Viewer. I think only most recent versions of Adobe Reader can handle it.
Title: Re: Form Fillable gibberish
Post by: Kyle Willey on April 11, 2012, 08:13:54 pm
I'm using Adobe Reader X (10.1.0), and I've had no issues with most other form-fillable PDF's, only the ones I've exported.
Title: Re: Form Fillable gibberish
Post by: Meho R. on April 12, 2012, 02:44:39 pm
I guess this is the same issue as this one (http://forums.scribus.net/index.php/topic,141.msg544.html). One user reported that the issue disappeared with Adobe Reader 10.1.1 update, so you might want to give it a try.
Title: Re: Form Fillable gibberish
Post by: Kyle Willey on April 15, 2012, 01:56:03 am
Ah, leave it to me to have the one version that has issues, and miss the thread about it.

Updating Reader makes it work fine.