Scribus Forums

Scribus => General Discussion => Topic started by: inkuser on December 13, 2019, 12:45:44 am

Title: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 12:45:44 am
Why would this be? The EPS art readily imports but the shape is very jaggy. I have Preview set to "Full Resolution."

A PDF of the same document shows the same EPS as less jaggy but still not sharp and crisp.

Thoughts?

Thank you!

EDIT: While I can't improve the display quality on the pasteboard, I can greatly vary the output quality to PDF.

It would be very nice for Vector EPS to appear razor-sharp in Scribus..maybe one day?
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: mnawij on December 13, 2019, 03:03:56 am
Hi inkuser,

Could you post the offending .eps file?  I have never seen this issue except with raster/bitmap .eps files and those that are of low quality/resolution.  Also which OS and version of Scribus are you using?  Are you using the import vector option or cut/paste the vector file into Scribus?

Cheers!

mnawij
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 07:03:37 pm
This forum doesn't permit attaching an eps and I don't have access to FTP to post it online. It's a 5-point star created in adobe illustrator, with a gradient fill and a different gradient stroke.

You can see the stairstepping of this graphic - after imported into Scribus - on the diagonals.

Method to get this image into my Scribus document:

Right click on picture box > Get Image

Thanks!

Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: a.l.e on December 13, 2019, 07:13:56 pm
- you can zip the eps and attach (i think)
- you can use a file sharing site like https://framadrop.org/
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 07:25:38 pm
OK..here we go.

also, using Scribus 1.4.8 on windows 10

Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: mnawij on December 13, 2019, 07:59:10 pm
When using the 'get image' option it does not bring in the object as a vector.  File -> Import -> Get Vector is the correct way to do this.  Also, gradients from Illustrator is 50/50 on whether or not Scribus will import them correctly in my experience.  I would export the object as a .tif, .jpg, .png, etc... file at 600-1200 dpi from Illustrator and import that image as a work around.

Cheers!

mnawij
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 08:01:03 pm
I can do that.

Thank you.
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: a.l.e on December 13, 2019, 08:09:34 pm
when imported as a vector, the eps looks share at any size...
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 08:15:00 pm
I can't import .eps "as vector"   

Just tried. I get the progress bar but it errors out with no explanation.
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: mnawij on December 13, 2019, 08:17:11 pm
My first guess would be the gradients.  Save the Illustrator file as a .pdf file version 1.5 and try the import vector file with that and let me know.

Cheers!

mnawij
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 08:23:22 pm
Just did that. No improvement, but worth a try!
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: mnawij on December 13, 2019, 08:35:00 pm
As attached, a gradient fill worked just fine though when trying to apply a gradient to the stroke, it would not import.  I hope this information helps.  If you could .zip up the .eps file for me to review and test it would help.

Cheers!

mnawij
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 08:39:06 pm
I posted it, a few entries up

thank you!
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: mnawij on December 13, 2019, 08:50:55 pm
My mistake, see attached files.  Scribus 1.5.3 file though.  I believe it has to do with the Creative Cloud new version.  I opened it in creative cloud, down saved to CS6, opened this file in CS6 and then down saved again to Illustrator CS2 version.  Seems to work.  I do not have Scribus 1.4 here to test...

mnawij
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 09:08:44 pm
these suggestions are excellent, but aren't improving things.

Does it matter that I'm using the Portable versions of Scribus and Ghostscript?
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 09:26:03 pm
I'm getting decent results exporting from Illustrator as SVG.

Maybe SVG is my horse!

 :)
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: mnawij on December 13, 2019, 10:17:42 pm
Did you try importing my pdf file into your version of Scribus?  This will help identify if there is an issue with your portable versions.  If you can import the pdf then it would be a problem with Adobe CC files and not Scribus per say.  Just an idea.

mnawij
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 10:25:38 pm
File > Import > PDF is not an option for my set up; PDF is not supported for "Import"

Thank you
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: mnawij on December 13, 2019, 11:11:35 pm
File -> Import -> Get Vector -> Choose pdf file

mnawij
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 13, 2019, 11:17:36 pm
That is what I did; I merely typed that as a shorthand way of telling what I did.

;-)
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: a.l.e on December 14, 2019, 09:17:39 am
so, importing the eps as vectors in 1.5 works perfectly...

but you wrote that you use 1.4...

and in 1.4 you can't import your file as vector (at leas i could not).

in this case you can load it in an image frame.

for the export you have to choices:

- you can activate the experimental embedding of pdf and eps (it's in the pdf export dialog) and you'll get a vector in your pdf, but you will lose the color management.
- or you can increase the resolution of the eps in the same pdf export dialog, in this case you'll get an high resolution bitmap in your pdf.

using portable version should not be a problem, but you will have to make sure that scribus detects ghostscript (and if you see a bad eps, it means that it works)

hope that this helped (and, sorry, yesterday evening i was in a hurry... and i missed the part about 1.4)

ciao
a.l.e
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 16, 2019, 06:49:29 pm
using portable version should not be a problem, but you will have to make sure that scribus detects ghostscript (and if you see a bad eps, it means that it works)

thank you, a.l.e.   Can you please clarify: "if you see a bad eps, it means that it works"  ?

Thank you!
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: RodneyLee on December 16, 2019, 06:58:11 pm
I dragged and dropped your eps into Scribus 1.5.5 and zoomed in a bit, Looks great to me
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: inkuser on December 16, 2019, 06:59:40 pm
looks like a good test!
Title: Re: EPS art appears stairstepped; ghostscript is installed
Post by: a.l.e on December 16, 2019, 07:25:45 pm
if you see an eps in the image frame, it means that ghostscript is detected.
if don't see anything, then the cause might be (and probably is) that ghostscript is not detected.

yes, i know that it might seem weird, but sometimes having bad results might be a sign that things work as intended... at least the relevant part of the things : - )