Scribus Forums

Scribus => Installation and Setup => Linux => Topic started by: starapple on December 20, 2018, 05:15:44 pm

Title: Questions about Scribus on Ubuntu 18.04 lts
Post by: starapple on December 20, 2018, 05:15:44 pm
(1) I just discovered and installed Scribus on Ubuntu Studio (18.04 LTS) and fond that two versions were installed, Scribus 1.4.6 and Scribus-NG 1.5.4. I'm not sure where I might have gone wrong. I did 'sudo add-apt-repository ppa:scribus/ppa' then 'sudo apt-get update' and finally 'sudo apt-get install scribus-ng'.

Should the result be two versions installed?

(2) During the installation several packages were removed, most critically, Calibre and OpenShot video editor. I'm wondering whether reinstalling these will result in the removal of Scribus.

The aim is to have a true multimedia studio environment with desktop applications for audio, video and text (print and electronic).
Title: Re: Questions about Scribus on Ubuntu 18.04 lts
Post by: a.l.e on December 20, 2018, 07:25:08 pm
hi starapple,

welcome to scribus.

it's hard to say what exactly happened.

first one fact: having to scribus installed is normally not a big issue... they can coexist.

you can for sure remove 1.4.6 is all you want to use is 1.5.4.

about calibre and openshot. not sure what has happened. you can of course try to install them again and, probably, everything is fine.
if there is a problem, you can try to remove the scribus you got from the PPA and see what happens.

you're setting up your system... so there is not much that you can break : - )
Title: Re: Questions about Scribus on Ubuntu 18.04 lts
Post by: starapple on December 20, 2018, 10:53:21 pm
Hi a.l.e, thanks for your response.

It seems apt removed some dependencies and added those needed to run Scribus-ng, without giving me an option to choose. I uninstalled Scribus/Scribus-ng and reinstalled OpenShot and Calibre using aptitude instead. This method presented a list needed files (dependencies) and options to install them.

I subsequently used aptitude to install Scribus and it did the job much quicker and more gracefully than apt-get.

So far I have only one missing dependency for OpenShot that was apparently removed during the first installation of Scribus so I'm trying to solve that now to get the reinstalled OpenShot to start.

To anyone using Ubuntu 18.04 LTS, I recommend using aptitude to install Scribus so you'll see exactly what is being added/removed and presented an option to accept, reject or read a help file on your choices--an option not offered using apt-get.

Hopefully I'll be able to get Scribus-ng working side by side with the other applications as I like the fact it has the CreateSpace book template...

Best.
Title: Re: Questions about Scribus on Ubuntu 18.04 lts
Post by: a.l.e on December 20, 2018, 11:25:15 pm
i also use aptitude, but with debian testing.

on this computer i don't have scribus-ng installed from the PPA, but all the dependencies for it are installed (since i compile it myself...).
if i try to install openshot i don't get any conflicts...

if you are really facing a conflict it might be worth to open a ticket on launchpad (the bug tracker for ubuntu).
the scribus PPA is actively maintained (big thanks to our maintainer!) and if he can do anything, i'm pretty sure that mattia will try to solve the issue!

can you give some details on which packages are creating the conflict?
Title: Re: Questions about Scribus on Ubuntu 18.04 lts
Post by: starapple on December 21, 2018, 12:52:52 am
Apparently I need to delete two libraries that won't move when OpenShot is uninstalled:
(1) /usr/lib/x86_64-linux-gnu/libopenshot.so.0.1.9
(2) /usr/lib/x86_64-linux-gnu/libopenshot.so.14

The latest is 0.2.2 so it's more an OpenShot than a Scribus issue although it was triggered when Scribus was being installed.