Scribus Forums

Scribus => Text and Typography => Topic started by: Depot 1 on August 26, 2011, 11:58:28 am

Title: Special characters disappear when importing text
Post by: Depot 1 on August 26, 2011, 11:58:28 am
Hi,
I have problem importing a text with danish characters. No matter which encoding I select, the danish characters does'nt show. If I copy-paste from the text file everything is ok.

Have anyboby encountered similar issues and found a solution?
Thanks!
Title: Re: Special characters disappear when importing text
Post by: Meho R. on August 26, 2011, 01:34:20 pm
Which version of Scribus? With 1.4.0rc5, I encountered no problems importing UTF-8 encoded text, be it from .txt file (with UTF-8 encoding), be it from .odt file created by LibreOffice Writer.
Title: Re: Special characters disappear when importing text
Post by: Depot 1 on August 26, 2011, 01:51:55 pm
I'm using 1.4.0 rc5.
It does'nt work for me when importing with UTF-8 encoding (or any other).
I've used Word to save the file as .txt, but now tried using Textedit instead and saving with UTF-8 encoding as well. That worked! So I guess I have to copy the Word-file to Textedit, and then save that file with UTF-8?
Title: Re: Special characters disappear when importing text
Post by: Meho R. on August 26, 2011, 03:41:42 pm
I'm not sure how Word functions, but try searching for ".txt (text encoded)" not plain .txt when exporting. Another option might be to install LibreOffice (http://www.libreoffice.org/) (it's free) and save as .odt document, then import it in Scribus (retaining all formatting and paragraph styles, if you wish). And, of course, you can do it the way you described ;)
Title: Re: Special characters disappear when importing text
Post by: Depot 1 on August 26, 2011, 03:56:02 pm
I don't think you can select encoding, when saving from Word. I'll just use the copy-paste method or download LibreOffice, as you recommended.
Thanks a lot for your help!