Scribus Forums

Scribus => PDF Generation => Topic started by: Ged on April 04, 2015, 08:08:09 am

Title: PDF properties do not show fonts
Post by: Ged on April 04, 2015, 08:08:09 am
When I export a Scribus page to PDF, the pdf properties are blank in the fonts tab.  No fonts are shown at all.

Attached is is a small PDF with only a regular Arial font, but not even Arial appears under fonts.  Why is that?  ???  This tab has always been detailed when I generated pdf's from my previous desktop program.

Perhaps I have overlooked something.  Can someone tell me what to do please?
Title: Re: PDF properties do not show fonts
Post by: Nermander on April 04, 2015, 12:22:21 pm
Did you choose to embed fonts?

There are settings in the PDF export dialog about what fonts should be embedded in the PDF.

Here are two exemple articles explaining this

http://www.newspaperclub.com/export-guide/scribus
http://www.linuxjournal.com/content/exporting-pdf-scribus
Title: Re: PDF properties do not show fonts
Post by: Ged on April 04, 2015, 07:22:07 pm
Yes, I tried to embed fonts, but Arial went to 'fonts to outline' instead.  Times New Roman does the same.  Then, after exporting, the pdf font properties remain blank.

The reason Im experimenting, is to find out whether one of the 'Export to PDF' options is causing my other problem on the Academia website.  (Scribd fails to convert my PDFs into readable Internet text)

Could this 'blank' in my pdf font properties be the source of my other problem?
Title: Re: PDF properties do not show fonts
Post by: Nermander on April 05, 2015, 10:07:58 pm
Some types of fonts can not be fully embedded, but they will usually be subset (which means the glyphs used are converted into a postscript font and embedded). In some cases however the glyphs may instead be converted to "drawn objects".

It seems as if the latter is what has happened, I am not sure why. It may depend on the fonts used or it may depend on the PDF version used. Or a combination of those.
Title: Re: PDF properties do not show fonts
Post by: Ged on April 06, 2015, 09:56:13 pm
Well, I dont know much about the technicalities, but I do think there is a glitch here in how Scribus saves to PDF.  Something is wrong.

My experimental paragraph written in 'Arial' was blank in the PDF properties.

Now, here is my previous page (file attached) which was written in 'Times New Roman'.  However, after exporting, the PDF font properties say 'Helvetica' and 'ZapfDingbats'  :o  How weird is that?
Title: Re: PDF properties do not show fonts
Post by: Nermander on April 07, 2015, 08:50:53 am
Since you seem to be the only user that has reported the problem I don't think the problem is in Scribus.

It may be some problem with your installation or you are misunderstanding some settings.
Title: Re: PDF properties do not show fonts
Post by: Ged on April 07, 2015, 09:27:58 am
Im beginning to wonder if it was because I uploaded Ghostscript after Scribus instead of the other way round?  I think Ill uninstall Scribus then install it again.  Maybe that will help?
Title: Re: PDF properties do not show fonts
Post by: Nermander on April 07, 2015, 09:34:28 am
Ghostscript isn't involved in this, this is a font embedding issue.

You have to make sure that when you export to PDF you go to the Fonts tab (in the PDF export dialog) and click the "Embed all" button before exporting, as shown in the two articles I linked to earlier.

You will often have to do this every time you export to PDF, since that tab is not automatically updated when you change fonts in your document.
Title: Re: PDF properties do not show fonts
Post by: Ged on April 08, 2015, 11:52:14 pm
Quote from: Nermander
You have to make sure that when you export to PDF you go to the Fonts tab (in the PDF export dialog) and click the "Embed all" button before exporting.

Hi Nermander,

When I look in the Fonts Tab, the available fonts box shows, Arial regular, Times New Roman regular, and TNR bold. That in itself is curious because I have not used Arial in my document.

Then, when I click "Embed All", Arial is embedded but the other two go down to "Outline."

Then, when I export, the PDF font properties say 'Helvetica' and 'ZapfDingbats'.  I am utterly confounded by what is happening and beginning to wonder if something is wrong with my computer.

Attached is my original Scribus (sla) file.  I hope Im not being a bother, but would you please export it to PDF and see if you get a better result?

Ged

Title: Re: PDF properties do not show fonts
Post by: Nermander on April 09, 2015, 09:22:55 am
Then, when I export, the PDF font properties say 'Helvetica' and 'ZapfDingbats'.  I am utterly confounded by what is happening and beginning to wonder if something is wrong with my computer.

What program is giving you those properties? Adobe Reader?
Title: Re: PDF properties do not show fonts
Post by: Ged on April 09, 2015, 10:04:25 am
Yes, Adobe Reader Xl
Title: Re: PDF properties do not show fonts
Post by: Nermander on April 09, 2015, 10:31:50 am
Could you maybe post screen captures of the different screens throughout the process?

Adobe Reader should show the names of the fonts as embedded in the PDF, so it's strange that it shows font names that were not shown in Scribus.

The Arial thing is that Scribus will embed the font that is set as a default font for text frames, even if no glyph from that font is used in the document.


One thing that struck me: Are you sure you are looking at the newly created PDF? Sometimes I have mistakenly exported to the wrong path and kept looking at the same old PDF instead of the newly exported one. Make sure to delete old incorrect PDFs and make sure you are exporting to the correct folder.
Title: Re: PDF properties do not show fonts
Post by: Ged on April 10, 2015, 04:01:01 am
Quote from: Nermander
Are you sure you are looking at the newly created PDF?
Yes, I deleted the old one first.

Attached are screenshots of the Font tab when exporting, and then when opening the new pdf in Reader.
Title: Re: PDF properties do not show fonts
Post by: GordCaswell on May 07, 2015, 06:59:00 pm
Based on those screenshots, it looks like Adobe is replacing (or possibly just labeling, anyone have an idea?) Arial with Helvetica, and the same with Times New Roman / ZapfDingbats.
Title: Re: PDF properties do not show fonts
Post by: pawsplay on May 08, 2015, 12:36:12 pm
I think the issue, which may also explain the problems I've been having, is addressed in this:

http://bugs.scribus.net/view.php?id=4564