Scribus Forums

Scribus => PDF Generation => Topic started by: JohnJR on February 08, 2017, 12:46:24 am

Post by: JohnJR on February 08, 2017, 12:46:24 am
 On an Error 403 message I was given a link to WEBMASTER.  Didn't work, this was the results (see screen shots (2)).


Post by: a.l.e on February 08, 2017, 11:57:06 am
hi john

well, there is not really a webmaster here... if you have questions just ask...

and if you want to get in touch with malex, just remove all "+" and "spam" from the address until you get something that looks like a real email address : - )

Post by: JohnJR on February 09, 2017, 12:01:27 am
Hi a.l.e,

Please let me apologize for the screaming headline.  The Error 403 message had "the WEBMASTER" link all in caps and I neglected to turn off my caps lock key for the subject line.

I note That my first screen shot didn't make it through (I see now you click on the little "more attachments" link rather than browse over the first one, note the befuddlement in this screen shot's last sentence).

I think the whole issue started because of and during my first post ever, I would go off into Google or the User Manual seeking answers and return to the post.  At that point, unbeknownst, I had been logged out automatically and would have to progress backwards, log in again and finish the post.  In this instance I must have made a slip-up in trying to do that, setting off this tangent.  It might have been because I hit the refresh button first.  I experienced about an hour's worth of problems before I could post again and my original post had disappeared.  I think something somewhere had decided for a while I was truly nefarious. 

The Error 403 message (one of those black letters on white background things) must have assumed I knew what 403 meant, offered me some computer-ese jargon routines I wasn't going to touch with a ten-foot pole; words like malware, viruses, cookies, etc.  It did seem to suggest that Firefox had "rejected" me and further hinted in layman's terms that I close my browser and open it again.  As a further precaution I restarted my computer before opening my browser again.  Nothing changed.

I can tell you there was another link called "you can fix this yourself".  A new black and white page came up and in place of Error 403 it was titled Bad Behavior and offered me more computer-ese routines that I wasn't going to touch with a ten-foot pole.  I went back to Error 403, or should I say Area 51, vaguely insulted that this link had fingered me as some sort of internet culprit, which I am not.  At that point I said to hell with it and hit the WEBMASTER link.  A blank pre-addressed email popped up (the one in question); I explained the problem and sent it off.  It bounced. Malex was the pre-address filled in.

This might help if this whole episode was in itself some sort of a scam directed at Scribus.  For about an hour afterwards I couldn't login to post from anywhere.  Going back to the post pages, "Hey JohnJR" was still in the top right corner but I couldn't post.  I needed to login.  Okay, I tried many things, going backwards and forwards with Google's arrow icons, logout, out, button from the post page and logging back in from my login page and the now blank login boxes at the top right hand corner--simultaneously when both appeared on the same page.  At one point, this started: "you do not have permission" pages that sent me back to a blank login page which I filled many times, click, "you do not have permission" back.  A two page loop.

At one point it prompted me that "JohnJR is not a valid user name".  Of course I had never put that in as my username, only my email.  I fretted about my password, sent for the email link to reset it (at least that worked), "reset" my password with the original and went back to my Pavlovian login circles--entering and reentering the same username email and password, back, repeat.  Somewhere in the loop, it worked.  Pavlov will have a persistent puppy now, I was restored to the New Topic post page and sent off this post first thing.

I do have a question with regard to the words above: malware, viruses, cookies, etc.  I have Macs and use my computer primarily as a word processing machine, my internet usage is sparing and confined to places like Wikipedia and so forth.  Downloading Scribus or Gimp is about as far out on a limb as I care to go.  I have always assumed/trusted that Apple and Firefox took care of things like this for me, but in light of this incident might you have an opinion or suggest I do something more proactive?


Before typing this, I hit the Post Button and nothing happened--frozen.  Preview button works, but not Post.  At the top of the page the "Hey JohnJR" is activated, I Google-arrowed back to a login page anyway and note my password is blank in both places on that screen (I have checked the "keep me logged in box" to stop this, but can't do anything about the 60 min. box).  I fill in my password, Google-arrow back to my post, click the Post button--nothing happens, still frozen.  Needless the say I'm back in my Palovian loop.  I think I saw one of those "you do not have permission", but what?  If you ever even get this post, please, please tell what I'm doing wrong--or what is wrong.  I've spent a better part of the day at this and it's frustrating nearly to the point of tears.

Post by: a.l.e on February 09, 2017, 10:43:41 am
well, the easy solution to most of your problems is to keep your posts short...

and if you cannot, you can write your posts in a word processing program, copy it and paste it in a fresh forum page.
(i use a slightly more complex version of this myself).

i don't think that we can modify the forum software to avoid those timeouts.

and, no, you cannot preview the attachments before sending them.

i will add a discussion on changing the software behind the forum, but i doubt that anybody will have the time to lead the change.

Post by: JohnJR on February 10, 2017, 12:35:27 am
Thanks a.l.e,

I realize that my verbose style can be excessive and tedious; even when it's a simple subject.  One reason I use it is that, many times reading forums--not just this one--for help with issues, questions and answers can seem clipped and assume a level of technical knowledge beginners don't have. The questions and their solutions, succinct as they may be, lose meaning and thus usefulness for the uninitiated.  Also I want to give you as respondents a flavor for understanding how intimidated and clueless many of us really are, but we are good people who work diligently to solve our problems first before we post, going back and forth.

Given this, your suggestion to compose all the minutia and then copy and paste it in is an excellent solution and one I'll use in the future.

In this case it seemed that something serious had been triggered with things like Error 403 links, Bad Behavior links, Browser rejections,
WEBMASTER pre-addressed emails that are undeliverable, "lack permission" and so forth.  All that seemed pretty scary to me and something I should layout in some detail for knowledgeable people to trace.  I had intuited that going back and forth over days with a post open probably logged me out (timeouts), but why the horror circles to just log back in again and, randomly, finally unfreeze the Post button.  It did take days.

Apparently none of this was even worth mentioning, but how am I to know; should I just shrug off and ignore such a sequence of events in the future?

I did resolve my attachments issue by noting that I should select the little "(more attachments)" link rather than browsing over the first browse button again.  This gives you a small image of each one and you can count the number of them to verify they're all in there.

I do note that something might have been smoothed out about the frozen Post button.  This morning I finished a similar post as the previous one above and with trepidation hit the Post button.  Noting happened, but at the top of the posting page a pink box appeared with a red simple message to the effect "your time has expired, please log back in" (cross your fingers).  I clicked that box and really did nothing else.  Scrolling back down I clicked the Post button again and the thing took off like it had a match lit under it.


Post by: JohnJR on February 19, 2017, 02:04:29 am
I must be doing something wrong; this happened to me again today.  I didn't try to solve it this time but here is a screen shot of the message.

Post by: a.l.e on February 19, 2017, 04:51:19 pm
i'm not sure about it, but i think it's related to the spam protection in the forum software.

i also had similar messages in the past and redoing the same action again, mostly got me through...

Post by: JohnJR on March 18, 2017, 01:18:33 am

After being in the forums awhile, and having problems related to these types of posting issues. For example: posting a reply (login-logged out-login to find your post has disappeared--sometimes completely); attaching files to a post that might be too big or too many in some unknown aggregate way without explanation (resulting in your entire post subject to disappearing as per above).  And so forth.  Posting even a brief reply or new topic nearly always is a crapshoot.  Very many times this really messes up a topic discussion and moderators seem equally befuddled, offering work- arounds, or trying to explain it as "clunky".

I suspect that the cause isn't really within Scribus, but a third party named (SMF).  If this is the case, or even if it isn't, can they, or anyone working on this straighten the posting mess out?

Post by: GarryP on March 18, 2017, 11:49:15 am
JohnJR, the forum website is a completely separate thing to the Scribus software.

The website uses software from Simple Machines so it works in the way it was designed and built by them, not the Scribus team. Most projects don't create their own website software - unless they are a website project - because it's a very big job and normally not necessary since other people have already done that for them.

You're correct - in my opinion - that the Simple Machines website software isn't very good, or to put it another way, it's not optimally functional for the way people use forums and what they want from them these days.

The Simple Machines forum software still works the way forums used to a decade ago but things move quickly on the web. Nowadays, people expect:
* to be able to see a live preview of their posts;
* their draft posts to be automatically saved;
* to be able to vote on posts;
* to have the ability to branch posts.
... and much more.

The Simple Machines software simply doesn't have any of this; well, you can see a preview of the text but not the attached images. Also, there's very little that the team can do about how the forum software functions. It works the way it does and all us users have just got to put up with it.

a.l.e started a thread a little while ago about a possible move from Simple Machines to Discourse,2328.0.html which sounds like a good move to me but whether anything happens is debatable. Someone needs to have a very good grasp of web technologies and have the time to put the effort in to testing and implementing a port from one system to the other.

If no-one volunteers then nothing will get done. If the person who volunteers doesn't have the right skills then nothing will get done. If the volunteer is correctly skilled but not trusted by the team then nothing will get done. If the person volunteering has the right skills and is trusted by the team but can't (for whatever reason) finish the job then nothing will get done. That all amounts to the same thing. A lot of things have to fall into place before anything will actually happen.

My advice - until something does happen - is to edit your posts in a text editor first and then copy/paste them into the website when they're ready to be posted. That way you can be reasonably sure that you won't be affected by timeouts. It's not a perfect solution but that's what I do and it works for me.
Post by: JohnJR on March 18, 2017, 07:11:45 pm
Hi GarryP,

It nice to know I'm not completely off my rocker.  The suggestion to use a word processor and then paste is a good one and appears in other forums.  Also I've taken to always Edit > Select All > Copy then paste.  As a word of caution using this path; remember to go back in and complete the Copy portion.  I have not on occasion and gotten back to a blank post window, hit Paste and found nothing was there--do over.

It might be helpful, and also forthright to do, if the maximum size (or number) of attachments were known and published; it could save a lot with that guessing game.

Post by: GarryP on March 20, 2017, 10:27:03 am
The maximum size and number of attachments is shown at the bottom of the "pop out" when you click on "Attachments and other options":
Restrictions: 5 per post, maximum total size 4096KB, maximum individual size 2048KB