Scribusoid

Author Topic: Text not saving when exporting to PDF  (Read 4641 times)

missy.

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Text not saving when exporting to PDF
« on: May 15, 2011, 04:19:54 am »
I just downloaded Scribus as an InDesign replacement for class. I'm using Scribus 1.4.0.rc3

I'm trying to make a letterhead, business card, and a webpage layout. For each layout, there's an image and text. When I export the file to PDF and preview it, the image shows up but not the text. Sometimes there will be text but it's not the text I saved or it'll save the larger text I used but not the small ones.

I tried updating my mac. Restarting the whole thing. And I dont know what else I could do.

Help ?  :(

Meho R.

  • Full Member
  • ***
  • Posts: 198
  • Karma: 0
Re: Text not saving when exporting to PDF
« Reply #1 on: May 15, 2011, 10:31:38 am »
If you use layers, double-check that you haven't accidentally ticked off "Print" option. Also, have you embedded all necessary fonts in the "Save as PDF" dialog? Can you upload an example .sla file which shows the issue (together with the resulting PDF file, for comparison)?

Nermander

  • Hero Member
  • *****
  • Posts: 1296
  • Karma: 17
Re: Text not saving when exporting to PDF
« Reply #2 on: May 15, 2011, 05:00:55 pm »
What are you using to view the PDF?

Adobe Reader is the one program that should always work.

missy.

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Text not saving when exporting to PDF
« Reply #3 on: May 15, 2011, 08:46:42 pm »
:D thanks you guys. i figured it out. -_-

it was what meho suggested : embedding the font in the save as pdf section. i thought i had done that but i guess i didnt understand that part fully. thanks again. i guess i will keep this topic open in case something happens.

:D THANKS

Meho R.

  • Full Member
  • ***
  • Posts: 198
  • Karma: 0
Re: Text not saving when exporting to PDF
« Reply #4 on: May 15, 2011, 10:00:42 pm »
An additional note regarding embedding: Scribus by default subset OpenType fonts instead of embedding them. So, in order to fully embed OT fonts as well, you'll have to tick off "Subset" in File > Preferences > Fonts for all OT fonts you'd like to embed.

 

palmate