Scribus > PDF Generation

can't copy text from generated PDF

(1/6) > >>

ronnietucker:
Hi folks,

For some reason I (and my readers) are unable to select and copy text from the PDF's that I'm generating from Scribus.

Each page has a text box that has four columns, the text for the text box is pasted into the Story Editor, and I then add any images on top of the text box. I do that for each article. I have several paragraph styles, one has the new Ubuntu font (which is what I mostly use) and one has a basic courier font style. The courier style WILL select/copy to the clipboard, but the Ubuntu style won't. But even when the courier style does select (for copying) it selects horizontally across the four columns, rather than top to bottom, left to right. This makes it impossible to copy programming code, or command line commands.

My PDF's can be downloaded from: http://fullcirclemagazine.org
and an archive of each issue from: http://wiki.ubuntu.com/UbuntuMagazine (under the /Translations section)

Any help would be much appreciated.

ronnietucker:
UPDATE:

I believe it has something to do with the new Ubuntu font. Scribus will embed the bold Ubuntu font, but will only outline the regular and italic fonts.

Is there any way to force embedding of the italic and regular, or is this a problem with the Ubuntu font itself?

The problem with selections going horizontal is still there though  :(

John_Jason_Jordan:

--- Quote from: ronnietucker on April 10, 2011, 04:31:00 pm ---UPDATE:
I believe it has something to do with the new Ubuntu font. Scribus will embed the bold Ubuntu font, but will only outline the regular and italic fonts.
Is there any way to force embedding of the italic and regular, or is this a problem with the Ubuntu font itself?

--- End quote ---

Go into Preferences > Fonts and check to see which check boxes are ticked for the fonts in question.

ronnietucker:

--- Quote from: John_Jason_Jordan on April 10, 2011, 07:28:02 pm ---
--- Quote from: ronnietucker on April 10, 2011, 04:31:00 pm ---UPDATE:
I believe it has something to do with the new Ubuntu font. Scribus will embed the bold Ubuntu font, but will only outline the regular and italic fonts.
Is there any way to force embedding of the italic and regular, or is this a problem with the Ubuntu font itself?

--- End quote ---

Go into Preferences > Fonts and check to see which check boxes are ticked for the fonts in question.

--- End quote ---

It has all four Ubuntu fonts (bold, regular, italic and bold italic) ticked for: 'Use Font', 'Embed In (Postscript)', and 'Subset'.

Meho R.:
Untick "Subset".

Navigation

[0] Message Index

[#] Next page

Go to full version