Author Topic: Dreaded PDF I and L problems with OFT font  (Read 7665 times)

c-m

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Dreaded PDF I and L problems with OFT font
« on: January 03, 2012, 12:41:34 pm »
I've used Scribus to produce a document that is intended for web.

I created a PDF and embedded the fonts (myraid pro OTF)

The PDF displays fine in Linux Mint 11, but when viewed on windows machines, there is a problem with the letter L and I

I'm using Scribus 1.3.3.13svn on Mint 11.

Please help

Nermander

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: 17
Re: Dreaded PDF I and L problems with OFT font
« Reply #1 on: January 03, 2012, 12:53:38 pm »
You left out the most important information: What program are you using to view the PDF?

Also, have you tried printing it? If a font lacks good hinting it may look bad on screen but perfect while printed (this is due to the difference in resolution).

Instead of printing you can also try to zoom in to for example 400%.

c-m

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Re: Dreaded PDF I and L problems with OFT font
« Reply #2 on: January 03, 2012, 01:10:22 pm »
You left out the most important information: What program are you using to view the PDF?

Also, have you tried printing it? If a font lacks good hinting it may look bad on screen but perfect while printed (this is due to the difference in resolution).

Instead of printing you can also try to zoom in to for example 400%.

Prints great in both windows and linux, but it's a CV so need to work in Adobe Reader 9 and above.

I read the information here: http://wiki.scribus.net/canvas/How_do_I_prevent_fonts_from_looking_ugly_in_the_exported_PDF_%3F

But in my version of Scribus going to File-->Preferences-->Fonts there is no "subset" option.


Nermander

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: 17
Re: Dreaded PDF I and L problems with OFT font
« Reply #3 on: January 03, 2012, 01:45:27 pm »
Why not write it in Open Office Writer (also free, and has native PDF export) instead?

I can't really see the point in using Scribus for a CV. Scribus has always been targeted at printing.

c-m

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Re: Dreaded PDF I and L problems with OFT font
« Reply #4 on: January 03, 2012, 01:56:07 pm »
Why not write it in Open Office Writer (also free, and has native PDF export) instead?

I can't really see the point in using Scribus for a CV. Scribus has always been targeted at printing.

For the same reason you might use indesign or quark. Aren't they applications for layout? Open office can't really do what I require. I might need to print the CV as well, and when creating reports I usually require an electronic copy for e-mail.

Nermander

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: 17
Re: Dreaded PDF I and L problems with OFT font
« Reply #5 on: January 03, 2012, 03:23:35 pm »
Well, but Scribus is targeted specifically at layout for printing. Other applications might be more general purpose and work well also for on screen design.

c-m

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Re: Dreaded PDF I and L problems with OFT font
« Reply #6 on: January 03, 2012, 03:25:58 pm »
Ah right.

Does that mean that there is no fix this problem then? That's unfortunate.  :(

Meho R.

  • Full Member
  • ***
  • Posts: 198
  • Karma: 0
Re: Dreaded PDF I and L problems with OFT font
« Reply #7 on: January 04, 2012, 01:03:45 am »
Can you create an example, with some dummy text, and post both .sla and resulting .pdf files showing the problem? I haven't noticed any problems with Myriad font, so I'd really like to see what the issue is (and the answer might actually be quite simple: an ancient version of Scribus; try upgrading to 1.4.0.rc6 and see if that worked in the first place).

In the attachment are two examples (created with version 1.4.0.rc5 on Windows), both using Myriad Pro OpenType font, subset and embedded, and exported with "Output indended for: Printer" in "Color" tab. I don't see any problems with display in Adobe Reader X. Please check.

utnik

  • Hero Member
  • *****
  • Posts: 1278
  • Karma: 14
Re: Dreaded PDF I and L problems with OFT font
« Reply #8 on: January 04, 2012, 01:54:48 am »
…try upgrading to 1.4.0.rc6…
why not to the final 1.4.0 version?

Nermander

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: 17
Re: Dreaded PDF I and L problems with OFT font
« Reply #9 on: January 04, 2012, 08:22:06 am »
Does that mean that there is no fix this problem then? That's unfortunate.  :(

Of course there is a fix: Use a font that has good hinting. As I wrote, the problems is most likely that the font has bad hinting. I think fonts intended for printing often lacks hinting information, because their intended use does not require it.

http://www.typotheque.com/articles/hinting

Meho R.

  • Full Member
  • ***
  • Posts: 198
  • Karma: 0
Re: Dreaded PDF I and L problems with OFT font
« Reply #10 on: January 04, 2012, 12:04:01 pm »
…try upgrading to 1.4.0.rc6…
why not to the final 1.4.0 version?

Oh my, I was just couple of days away and it's out in the meantime :D Thanks for the correction. Definitely the final 1.4.0 version, yes.

c-m

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Re: Dreaded PDF I and L problems with OFT font
« Reply #11 on: January 04, 2012, 12:09:34 pm »
Upgraded to the very latest version. It's so much better. I opened the same document, it converted it to 1.4 format. I then created a PDF and tested it on my local windows machine and on a terminal server, both running adobe reader. The display was flawless.

Thanks guys.

P.S on the new version I still can't find the setting to turn off "subset"

Meho R.

  • Full Member
  • ***
  • Posts: 198
  • Karma: 0
Re: Dreaded PDF I and L problems with OFT font
« Reply #12 on: January 04, 2012, 02:16:17 pm »
...

P.S on the new version I still can't find the setting to turn off "subset"

It's in File > Preferences > Fonts. Just move horizontal scrollbar a little bit to the right and you'll see it.

c-m

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Re: Dreaded PDF I and L problems with OFT font
« Reply #13 on: January 04, 2012, 02:21:04 pm »
Thanks.

Note to self - engage brain before posting

 

palmate