Scribusoid

Author Topic: Scribus not recognizing newly installed fonts  (Read 567 times)

rowlandr

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Scribus not recognizing newly installed fonts
« on: February 14, 2019, 11:15:37 pm »
For a new project I downloaded and successfully installed new True Type fonts into the Windows 10 Windows/Fonts directory. Now I have a Scribus problem I didn't have before with the fonts installed prior to installing Scribus and working on previous projects.  Scribus doesn't recognize the newly installed fonts.
These fonts are Scribus compatible--recommended on another site for a book project I am now working on.
I have verified that the fonts are properly installed in the /Fonts directory.   Closing Scribus and reopening doesn't help. The Scribus Font list under preferences doesn't list the new fonts.  Shutting down the computer and restarting yields the same results.
Solutions please.

thanks

RR

mnawij

  • Sr. Member
  • ****
  • Posts: 252
  • Karma: 2
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #1 on: February 15, 2019, 05:45:57 am »
rowlandr see if this link helps.

http://forums.scribus.net/index.php?topic=2918.0

Cheers!
mnawij

rowlandr

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #2 on: February 15, 2019, 06:19:54 am »
I have the problem mentioned at the end of that post you pointed to.
When I open Scribus and try the Fonts  "add" function it doesn't see the Windows/Font folder.
That's even though Scribus in the main font menu does recognize every font that existed in the Windows/Font folder prior to installing Scribus a while ago.
As I said it appears that Scribus has no problem with any font (as far as I can tell) that existed in the Font folder prior to installation of Scribus only ones added since I installed Scribus.
The new fonts I first installed are

EB Garamond
Sorts Mill Goudy

which are recommended on a couple of sites and therefore should be fully compatible with Scribus.  These were installed a couple of weeks ago and today I installed a couple of symbol fonts GE Nautica and Significante (the project I am working on is a sailor's guide book)

I can substitute the already installed Garamond if need be.   I would like to be able to use the symbols for some parts of the book.

Whether I installed the new fonts a couple of weeks ago or today, Scribus can't find them

thanks for your help.

RR



mnawij

  • Sr. Member
  • ****
  • Posts: 252
  • Karma: 2
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #3 on: February 15, 2019, 06:23:53 am »
The font folder in Windows is usually a hidden file... have you tried turning on hidden folders system wide before opening Scribus?

mnawij

rowlandr

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #4 on: February 15, 2019, 06:33:29 am »
I am a techy reaching back to the 80s.  So none of my Windows folders, including Fonts are hidden at the moment.

thanks

RR

mnawij

  • Sr. Member
  • ****
  • Posts: 252
  • Karma: 2
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #5 on: February 15, 2019, 07:21:38 am »
One more question are they ttf or otf file types?  Also would you share the font files so I could install them and try them in Scribus?

mnawij

Update: I got the fonts from google fonts... I installed them in both Mac OSX/Scribus 1.5.4 as well as Linux Mint Debian/Scribus 1.5.4 flatpak and everything worked fine.  I do not have a Windows box here but tomorrow at work I will install the fonts on my Windows 10 machine.  Which version of Scribus are you using so I match everything up correctly with yours.

mnawij
« Last Edit: February 15, 2019, 07:35:47 am by mnawij »

rowlandr

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #6 on: February 15, 2019, 07:48:10 am »
The files are ttf
I am trying to upload zip files but board keeps rejecting them either as too large or other problem.
This time I will try the smallest zip file (symbols not alphanumeric)



thanks

RR

rowlandr

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #7 on: February 15, 2019, 07:49:24 am »
The alphanumeric font zip files are "too big" or other problem
And ttf is not a recognized upload for this board

thanks

RR

rowlandr

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #8 on: February 15, 2019, 08:05:58 am »
Here is one of the Garamond fonts which the book site said was Scribus compatible.
I have taken it from the TTF subfolder but the info says it is Open type layout True Type Outline

RR

mnawij

  • Sr. Member
  • ****
  • Posts: 252
  • Karma: 2
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #9 on: February 16, 2019, 02:15:56 am »
rowlandr,

In a previous post here I shared an update that I found the fonts on Google Fonts site.  I installed them in Linux Mint DE, Mac OSX, and today I installed them on my Windows 10 box and had no problems using the fonts. Did you get them from Googles Font Site or other free font site?  I would recommend uninstalling the fonts and download them from a different location if possible and reinstall them.  Otherwise I am out of ideas...

cheers!

mnawij

rowlandr

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #10 on: February 16, 2019, 02:55:03 am »
Thanks for the suggestion. But that didn't work. I downloaded  the Google version  of  EB Garamond directly from the Google Fonts site, and Scribus still can't find it.  Unless you or someone else on the forum can find a solution, i may have to uninstall and reinstall Scribus to see if that works.  As I said originally, it appears that Scribus can  recognizes fonts that existed in the Windows Folder prior to the original installation, no matter where I downloaded them from but nothing new.  It may be a bug of some kind

RR

rowlandr

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #11 on: February 16, 2019, 03:43:35 am »
I figured out a workaround.
You have to add the top Scribus/share/fonts folder in the add fonts
Then you copy the fonts you want from the  Windows/Fonts folder or if have downloaded them to a download folder then copy to the /share/fonts folder
All but one of the fonts I needed are now working in Scribus.

But it is clear to me that there is a bug since no new fonts are recognized  in the Windows/Folder

RR

mnawij

  • Sr. Member
  • ****
  • Posts: 252
  • Karma: 2
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #12 on: February 16, 2019, 04:25:07 am »
I will have to remember that font location for Scribus for future problems.  I am not sure it is a bug since I was not able to reproduce the problem, maybe someone else can try.  You never mentioned which version of Scribus you are using as I did my testing in 1.5.4.  If you are using 1.4.7 I will have to run the testing over again to verify.

mnawij

rowlandr

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #13 on: February 16, 2019, 05:58:12 am »
I am using 1.4.7

RR

AdmFubar

  • Newbie
  • *
  • Posts: 25
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #14 on: February 18, 2019, 06:11:31 am »
I avoid putting fonts in the system fonts. I make a separate directory for them, and point  Scribus to that. that way i am not cluttering up the system font folder with fonts for DTP work.

 

palmate