Author Topic: Scaling group of shapes doesnt work?  (Read 198 times)

Gibbz

  • Newbie
  • *
  • Posts: 25
  • Karma: 0
  • Scribus User
Scaling group of shapes doesnt work?
« on: October 19, 2018, 01:50:53 am »
I have an odd issue, im wondering if it is a bug.

If i import some text from a pdf, then group those objects. Then try to scale that group (holding ctrl to scale evenly). Then the shapes move, dissapear and dont scale...

Has anyone noticed this issue? Is there a fix for it?

Thanks :)

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1620
  • Karma: 23
    • the graphics lab
Re: Scaling group of shapes doesnt work?
« Reply #1 on: October 19, 2018, 03:38:39 pm »
If this happens in 1.4, you should probably accept it as a restriction related to the way groups are implemented there...

If it happens in 1.5, i'd be interested in knowing more about it...
can you share a sample .sla with instructions how to trigger the issue?
or show a screencast?

ciao
a.l.e

Gibbz

  • Newbie
  • *
  • Posts: 25
  • Karma: 0
  • Scribus User
Re: Scaling group of shapes doesnt work?
« Reply #2 on: October 29, 2018, 06:28:29 am »
Ive put in 2 separate bugs for scaling in 1.5.4.

One for pdf imported objects.
The other for plain text frames.

https://bugs.scribus.net/view.php?id=15465
https://bugs.scribus.net/view.php?id=15464

These are pretty painful ones as they affect something that's done regularly on a daily basis...

Thanks for looking at these :)

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1620
  • Karma: 23
    • the graphics lab
Re: Scaling group of shapes doesnt work?
« Reply #3 on: October 29, 2018, 10:47:48 am »
thanks!

 

palmate