Author Topic: custom colors for text broken in 1.5.4  (Read 205 times)

Raymund

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
custom colors for text broken in 1.5.4
« on: September 21, 2018, 08:35:46 pm »
Hi, I recently upgraded to 1.5.4 on Manjaro Linux running the 4.14.70-1 LTS kernel. I opened a file created under a previous version of Scribus that had some custom colors for text fill and shadow. Those custom colors appear normal in existing text objects. When I created a new text object and tried to apply the same custom colors, the application of the colors failed, and the text fill and shadow are both white.

I attach an image. The words "TO ALL" are original, with custom black and blue. The letters "CON" should have the same custom black and blue, but instead appear white.

I created new custom colors with the same RGB settings as the prior ones using the Edit > Colors and Fills > Add dialogue box. The new custom colors also failed to be applied to the new text object.

I've activated color management in both File > Preferences and File > Document Setup. After doing so, applying both the earlier custom colors and the new custom colors also fails.

mnawij

  • Full Member
  • ***
  • Posts: 216
  • Karma: 2
  • Scribus User
Re: custom colors for text broken in 1.5.4
« Reply #1 on: September 22, 2018, 07:16:46 am »
Hello Raymund, could you please attach your scribus file to look at, to see if the same problem(s) occur on other scribus apps?  Thanks!

mnawij

Raymund

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: custom colors for text broken in 1.5.4
« Reply #2 on: September 22, 2018, 04:26:14 pm »
Hi mnwaij,

Here's the scribus file.

utnik

  • Hero Member
  • *****
  • Posts: 1236
  • Karma: 14
Re: custom colors for text broken in 1.5.4
« Reply #3 on: September 22, 2018, 09:38:26 pm »
hi raymund

the colors are the same, but in the lower line the saturation is set to 0%.

utnik

Raymund

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: custom colors for text broken in 1.5.4 [SOLVED]
« Reply #4 on: September 24, 2018, 06:49:40 pm »
Hi utnik,

Thanks, that solved the problem.

For anyone else with this text saturation problem, I could only fix it by selecting text in the text box, going to Text Properties (or F3), and changing the saturation to 100%. I was unable to change the saturation in Story Editor. IDK if that's a Linux-only issue or if it would apply to other platforms too.

 

palmate