Author Topic: side by side installs  (Read 572 times)

mnawij

  • Full Member
  • ***
  • Posts: 212
  • Karma: 2
  • Scribus User
side by side installs
« on: March 02, 2018, 02:02:58 am »
I have read that you can have both 1.4 & 1.5 installed at the same time on the Mac, but what I am asking is if anyone has actually done it and has had no problems using both?  I have had zero problems with 1.5, but to help answer questions here, I would like to be able to run 1.4 also.

Thanks!

mnawij

utnik

  • Hero Member
  • *****
  • Posts: 1222
  • Karma: 14
Re: side by side installs
« Reply #1 on: March 02, 2018, 06:11:32 am »
hi mnawij

i have always more than one copy of scribus on my mac. at the moment there are 1.4.6, 1.5.3 and 1.5.4-r22418. sometimes i run 1.4.6 and one of the 1.5.x versions at the same time without any problem.
i don't run 1.5.3 and 1.5.4 at the same time, as the same settings are used – but even that might work…

utnik

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1525
  • Karma: 22
    • the graphics lab
Re: side by side installs
« Reply #2 on: March 02, 2018, 09:50:14 am »
on linux i can even run multiple copies of the same version in parallel...
... and, yes, the last one getting closed stores the list of recently opened files and the settings...

on linux and mac it's possible to have as many copies as you want of any version of scribus.

on windows it's possible as long as they are installed with different names (which should be the case for 1.5.x and 1.4.x).

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: side by side installs
« Reply #3 on: March 02, 2018, 11:10:50 am »
The easiest way to have two different copies of Scribus installed on OS X is to put one in the system Applications folder and one in your personal Applications folder. (With OS X, I don't think the operating system cares where you install an application, the Application folders being more of a suggestion than a requirement.)

As with the two replies already given, I had no problems with 1.4.x and 1.5.x being installed at the same time (quite a while ago).

 

palmate