Author Topic: Scribus not recognizing Arial Italics Font (Windows 10)  (Read 113 times)

Leonard03

  • Newbie
  • *
  • Posts: 7
  • Country: 00
  • Karma: 0
  • Dual Monitors FTW
Scribus not recognizing Arial Italics Font (Windows 10)
« on: May 09, 2017, 06:01:23 pm »
Just installed Scribus (1.5.2) on a new computer to continue on with my previous project. since I was running Lubuntu and now I've got Windows I had to change a couple fonts in the project, which is when I noticed something strange. Scribus did not list Arial Italics as an available font. At first I wondered if it just wasn't installed for some reason, but after double checking in the font control panel I can confirm it's there. All the other Arial fonts show up (Regular, Black, Bold, Bold Italics) but no regular italics.
Any ideas?
<insert witty line here>

Hilvern

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing Arial Italics Font (Windows 10)
« Reply #1 on: May 25, 2017, 07:05:38 pm »
Hello Leonard.

I have been having the very same issue on Scribus 1.5.2 since I started re-using it in March.

When loading a previous project from last year (produced with Scribus 1.4.6 I believe), I keep having a textbox during startup requesting me to substitute Arial Italic (supposedly absent from my system) with another font.

On the list of fonts available for replacement (screenshot_002) you can see that Arial Italic is part of the list, but seems to not be recognized as a TrueType or OpenType font by Scribus, and therefore not available for display.

Unfortunately I haven't found a workaround, but I wanted to describe this problem too so it can be solved in the 1.6 version to come.

 

palmate