Scribusoid

Author Topic: no colors shown under fill color properties  (Read 314 times)

Guillaume

  • Newbie
  • *
  • Posts: 10
  • Karma: 0
  • Scribus User
no colors shown under fill color properties
« on: April 20, 2017, 08:24:14 pm »
The intention is to fill background color in empty text frame by clicking on paint bucket, but  no colors come up.  (Clicking on paint brush makes line colors come up though  and I can apply color to border, no problem here.)  So what am I missing?

CGood

  • Full Member
  • ***
  • Posts: 108
  • Karma: 0
  • Scribus User
Re: no colors shown under fill color properties
« Reply #1 on: April 21, 2017, 03:10:21 am »
If you want to fill the entire text frame, go down to the colors tab down at the bottom of the properties palette - not part of the text tab - and then you have to select the color you want. You should see the frame fill immediately. If I'm misinterpreting what you want, please ask again and someone will help out.

GarryP

  • Hero Member
  • *****
  • Posts: 1302
  • Karma: 19
  • Scribus User
Re: no colors shown under fill color properties
« Reply #2 on: April 21, 2017, 12:14:55 pm »
Just to expand on what CGood said above, the "Line" and "Colour" tabs of the Properties Palette are connected to the frame (or shape) while the "Colour & Effects" area of the Text tab of the Properties Palette is concerned with the text within a text frame. It's an easy mistake to confuse the two.

The colours defined in Scribus should be available anywhere you can select a colour. There is no distinction between line and fill colours, there are just colours that can be used. If you can select more colours from one tool than you can from another tool in the same document then that may be a bug but more information will be needed to sort it out. (There may be cases where this is allowed but I can't think of any off the top of my head.)

One extra thing: Don't use a text frame if you just want a coloured shape. Use a shape instead. Using a text frame for a coloured shape is possible - and it works - but it's using the wrong thing for the job. When you come to export the document you will get a message from the Pre-Flight Verifier saying that the text frame is empty. This may cause you extra time and hassle trying to find out what is wrong.

Guillaume

  • Newbie
  • *
  • Posts: 10
  • Karma: 0
  • Scribus User
Re: no colors shown under fill color properties
« Reply #3 on: April 21, 2017, 09:05:38 pm »
Thanks for the replies but, the solution was under my nose.  I had  been wondering about a blue line under the two icons:  the brush and the bucket.  That blue line was not a line but the color of the "none" selection.  I happened to click on that line, and it suddenly expanded into the color assortment.  Voila!