Author Topic: Which Version to Use?  (Read 1108 times)

stephentianBookDesigner

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Which Version to Use?
« on: December 01, 2016, 12:31:12 am »
I’m working on an iMac running the Sierra OS. I currently have Scribus 1.4.6 on the machine, carried over from my previous iMac. But I’d like to run the latest version on a project if at all possible. I see there are development versions 1.5.1 and 1.5.2 available. How safe are these development versions? Is it a bad idea to try to get real work done with a development version?

Thank you.

Steve Tiano

================================================================
Stephen Tiano
Book Designer, Page Compositor & Layout Artist

tel. & fax: (631)284-3842 / cell: (631)764-2487
Skype: stephentianobookdesigner
FaceTime: Stephen Tiano
email: steve@tianobookdesign.com

website: http://www.tianobookdesign.com
blog: http://tianobookdesign.com/blog
twitter: http://twitter.com/StephenTiano

Facebook: Stephen-Tiano-Freelance-Book-Designer-Page-Compositor-Layout-Artist
LinkedIn: Stephen Tiano
================================================================

mnawij

  • Full Member
  • ***
  • Posts: 122
  • Karma: 1
  • Scribus User
Re: Which Version to Use?
« Reply #1 on: December 01, 2016, 01:36:53 am »
Hi Steve,

I have been using 1.5.2 on Mac OSX for several months now for graphic design/document layout and have had only a couple minor hitches but in no way kept me from completing the projects.  I have completed over 50 projects of business cards, brochures, postcards, flyers, stationery etc...  my only difference is that I run 10.9.5 as I have several applications that will not work if I upgrade.  You can have both versions installed side by side on the Mac, I have had no issues with this either, except everything opens in 1.5.2 if opened by double clicking on the file.  I would recommend to keep on using 1.4.6 for important projects, but slowly use 1.5.2 for the less important jobs until you feel comfortable that you will not have any problems with your workflow.

Regards,

mnawij

GarryP

  • Hero Member
  • *****
  • Posts: 1302
  • Karma: 19
  • Scribus User
Re: Which Version to Use?
« Reply #2 on: December 01, 2016, 12:22:44 pm »
For most people I'd recommend them sticking with the latest stable version (currently 1.4.6).

That version has been around for quite a while and its functionality is well known and documented as a lot of people use it. This means that most people who use it on a regular basis know how it is supposed to work and what weird little "ticks" it sometimes does which aren't wanted but are expected.

This means that if you have a problem with the stable version it's much more likely that someone already knows about it and can advise accordingly. In these cases a solution is usually quick to find and you can move on with your project.

On the other hand, developmental versions are used by a much smaller subset of the Scribus user base (judging by the SourceForge weekly downloads data) and as such, when a problem occurs, there are fewer people that can help which means that a solution can take longer to find. Also, developmental versions are, by their nature, unstable which means that they might contain features that haven't been tested fully or they might do things in a different way.

SIDEBAR: If someone is a Scribus beginner and they come across a problem with a developmental version, how do they know if the problem is a bug or whether it's a new feature or they're just not using the software correctly? They have no baseline for comparison and people who haven't used the latest version won't know about the new features. I've seen plenty of "bugs" reported that are just the result of people not knowing what they are doing.

Not only that, but for some developmental versions you can have a lot of different "sub-versions" all masquerading under the same version number, all with slightly different functionality as bugs get fixed and the changes get implemented into the latest one. This means that one person's 1.5.x which was compiled last week probably won't be the same as another person's 1.5.x which was compiled today.

In cases like this it's very difficult for anyone to bug-fix as it can be very difficult to find/compile the exact version the problem is occurring in in order to see what's going wrong. Because of this someone will probably recommend that you install a copy of the latest version you can find and see if that makes a difference.

So what does all this mean? In my opinion there are three reasonable options:

1. Stick with the stable version. Most people use it and you can get support quickly. It's not perfect and it doesn't have all of the latest bells and whistles but if you're working to a deadline and need answers quickly then that's the best option.

2. Use the stable version until you can go no further, then create a copy of your document and take that over to the latest version to add the "extras" while you still have a stable version of the document you can go back to if you get into trouble. (I.e. You can't take a 1.5.2 document back into 1.4.6; Scribus documents aren't backwards compatible.)

3. Take the time to find out how you can get - and properly keep up-to-date - the "bleeding edge" version (most likely by compiling it yourself). This will contain any bug-fixes that have been made lately and should have fewer problems than any previous developmental versions. However, you need to use that with the knowledge that something could - but might not - go horribly wrong.

To expand a little on what mnawij said above, a lot of people use the latest developmental version without much trouble. No software is bug-free so it's your own choice which path to follow. If you have doubts or worries then install both versions - stable and developmental - and use the stable version for the important stuff while experimenting with the developmental version.

You might find that you prefer the stable version, and that's fine. On the other hand you might find that the extra features of the developmental version outweigh the (potential) problems and prefer that version instead, and that's fine too.

There is no right or wrong answer. Use what you're most comfortable using while being aware of the potential risks either way. With the stable version you're risking not having all of the latest features which could be helping you do things better but, on the other hand, with the developmental version you're risking using software that could bite you at the worst moment.

P.S. On Macs, one easy way of having both versions is to install the stable version in the system Applications folder while installing the developmental version in the Applications folder in your user folder.

mnawij

  • Full Member
  • ***
  • Posts: 122
  • Karma: 1
  • Scribus User
Re: Which Version to Use?
« Reply #3 on: December 02, 2016, 06:20:27 am »
Thanks GarryP about the install locations, maybe that information could be added to the install/download page, I put both version in the system application folder...

mnawij

GarryP

  • Hero Member
  • *****
  • Posts: 1302
  • Karma: 19
  • Scribus User
Re: Which Version to Use?
« Reply #4 on: December 02, 2016, 02:49:25 pm »
You're welcome mnawij.

I agree that adding that tip to the relevant download/install page(s) would be a good idea. It helps to keep things nice and separate.

I also think some similar instructions could be added for Windows and Linux users. I'm not advocating that people (in general) use developmental software - I think it should only be used by people who really know what they're doing with the stable version - but if people are going to use it then it seems wise that the team should give them instructions on how to do it safely.

Maybe this will filter through to whoever maintains the web sites.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1200
  • Karma: 18
    • the graphics lab
Re: Which Version to Use?
« Reply #5 on: December 02, 2016, 03:28:53 pm »
i would also put both versions in the "normal" application folder...

... and rename each of them with the version number at the end:

- scribus 1.4
- scribus 1.5

or name "scribus" the one you normally use and put the version number on the other one.

mnawij

  • Full Member
  • ***
  • Posts: 122
  • Karma: 1
  • Scribus User
Re: Which Version to Use?
« Reply #6 on: December 03, 2016, 07:02:35 am »
a.l.e., my problem is when I double click the filename to open, it always opens in 1.5.2, when I would prefer the default to be 1.4.6 when double clicking on the file to open...

mnawij

utnik

  • Hero Member
  • *****
  • Posts: 1051
  • Karma: 12
Re: Which Version to Use?
« Reply #7 on: December 03, 2016, 10:19:16 am »
hi mnawij

…when I double click the filename to open, it always opens in 1.5.2, when I would prefer the default to be 1.4.6…

it's the same here – unless 1.4.6 is already running (and 1.5.x isn't…)
otherwise i need a right click to open a file with 1.4.6 – not a big deal…

utnik

GarryP

  • Hero Member
  • *****
  • Posts: 1302
  • Karma: 19
  • Scribus User
Re: Which Version to Use?
« Reply #8 on: December 03, 2016, 11:29:16 am »
a.l.e: The benefit of using two different Applications folders is that the user doesn't need to rename anything. Not everyone is comfortable with renaming applications (and I believe it also destroys any app/file relationships that have been created, see below). Having the system Applications folder for "normal" applications while using the user Applications folder for trials/development/testing is a good way of keeping things separate. This way you can install/remove applications without affecting your "production environment" (up to a point anyway).

mnawij & utnik: If you right-click an SLA document in Finder you can set which application - or copy of the application - opens SLA files. I don't have access to my old Mac at the moment but, if I remember correctly, there's a section in the Properties dialog that allows you to set the application you want to relate this file type with. There's also a checkbox to say whether you want to force that new setting for all documents of that type. (Installing a newer version version will overwrite this so it will have to be done every time a new version of Scribus is installed.)

utnik

  • Hero Member
  • *****
  • Posts: 1051
  • Karma: 12
Re: Which Version to Use?
« Reply #9 on: December 03, 2016, 01:50:19 pm »
hi garry

…Installing a newer version version will overwrite this so it will have to be done every time a new version of Scribus is installed.

yes, there is such a section in the file properties dialog, but this setting will be immediately overwritten if there's already a newer version of the app installed.

utnik

GarryP

  • Hero Member
  • *****
  • Posts: 1302
  • Karma: 19
  • Scribus User
Re: Which Version to Use?
« Reply #10 on: December 03, 2016, 02:25:39 pm »
Ah, I didn't know if OSX automatically used the latest version when more than one was available. Oh well. (I always open Scribus documents from within Scribus so I don't have this problem. Old habits die hard.)