Author Topic: pdf created from sla doesn't show images  (Read 971 times)

JohnB47

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
  • Scribus User
pdf created from sla doesn't show images
« on: May 17, 2016, 06:55:25 pm »
Hi.

This has been working for me before but now, using the same sla, the exported pdf is missing the images. Everything else is there. Wierd. What could I have done to stop images being exported? The sla is saved first and all the usual boxes are ticked in the export window.

Oh, I've just discovered that if I open the document with Adobe PDF Reader, all is present and correct. But when I open the pdf in Scribus, it's missing the images. Ideas?

Or, to ask the question in a different way. I've created a business card in one sla and a layout template in another sla. The business card (BC) has a number of layers. So I'd planned to save the BC as a pdf, then with both the template sla and the pdf open, I'd copy and paste the flattened card document into the template slots. Now that I can't see the images in the saved pdf, this won't work. Has anyone any ideas how I can copy a multi layer document in one sla to another sla? That would avoid this problem, which is so odd. It was working earlier, now it isn't.

Thanks.
« Last Edit: May 17, 2016, 08:43:25 pm by JohnB47 »

Nermander

  • Hero Member
  • *****
  • Posts: 1131
  • Karma: 15
Re: pdf created from sla doesn't show images
« Reply #1 on: May 17, 2016, 09:22:31 pm »
Scribus isn't really intended to open PDFs.

JohnB47

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
  • Scribus User
Re: pdf created from sla doesn't show images
« Reply #2 on: May 17, 2016, 11:50:04 pm »
Thanks.

While waiting for a reply, I decided to use a trick I read about in another thread.

I took the card sla and deleted each layer in turn, from the top, but chose not to remove the objects on it. That compresses things down a layer. Doing this repeatedly creates a one layer file, which contains all objects that were on seperate layers. I can then copy and paste this into my template without making an intermediary pdf. Works for me but seems clumsy. Why is there no 'flatten all layers' option? Seems an odd omission.

Cheers.

solaero

  • Newbie
  • *
  • Posts: 31
  • Karma: 0
  • Scribus Moonlighter
Re: pdf created from sla doesn't show images
« Reply #3 on: May 18, 2016, 02:40:54 am »
Why not use a Master Page for your template? Seems to me that's kind of what you are doing with the PDF.

Nermander

  • Hero Member
  • *****
  • Posts: 1131
  • Karma: 15
Re: pdf created from sla doesn't show images
« Reply #4 on: May 18, 2016, 09:51:31 am »
From what I understand he wants to take a PDF of his business card and place several times in a document to get sheets to print.

So it's rather a matter of impositioning.

It should be possible to import the PDF into image frames to get the desired effect. Just don't forget to check the option to embed pdf/eps when exporting the resulting PDF.

JohnB47

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
  • Scribus User
Re: pdf created from sla doesn't show images
« Reply #5 on: May 18, 2016, 02:39:35 pm »
Thanks guys. First, may I say that I realise now that I've started this thread in completely the wrong section of this forum. I will be more careful in future but will continue here with this one.

OK, I see the mention of Master Page. I've had a look at the wiki about this but I'm still not sure if it would help. Just to repeat the problem: I have a multi layer Scribus document (Card.sla) that I want to copy and paste into a layer of another multi layer Scribus document (CardTemplate.sla). I though this would be dead easy; the sort of thing people would want to do all the time. Presently, I can do this by first flattening the layers in Card.sla using the crude method mentioned in my earlier post, then 'select all' and copy/past that document into CardTemplate.sla.

Would Master Page help here? If I convert Card.sla to a Master Page, will it flatten the layers for me automatically? Sorry, I can't access Scribus at the moment - will try this later today.

Otherwise, how do folks copy a multi layer page from one Scribus document to another - surely this must be needed occasionally?

Thanks for the help.

Nermander

  • Hero Member
  • *****
  • Posts: 1131
  • Karma: 15
Re: pdf created from sla doesn't show images
« Reply #6 on: May 18, 2016, 04:18:20 pm »
I have never done it, but I think there is a way to select all content in all layers instead of just the active layer (most likely a keyboard modifier).

Another option may be to import Card.sla into CardTemplate.sla instead of pasting. But maybe that imports the page size too...




JohnB47

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
  • Scribus User
Re: pdf created from sla doesn't show images
« Reply #7 on: May 18, 2016, 04:59:29 pm »
Thanks.

What is a keyboard modifier? How would I investigate if one exists? I'll play with your other idea later today.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1256
  • Karma: 18
    • the graphics lab
Re: pdf created from sla doesn't show images
« Reply #8 on: May 18, 2016, 05:31:22 pm »
the feature is in 1.5.x

you can activate the "cross-layer" selection in the layers palette (for each layer)

in 1.5.1 you can do so with the mouse.

if iirc in 1.5.2 you can also do so with the "select all" command (ctrl-a)