Scribusoid

Author Topic: Image pattern: Gaps, low resolution  (Read 1258 times)

ZoltanE

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Image pattern: Gaps, low resolution
« on: April 10, 2016, 07:27:47 pm »
I made a pattern by loading an image. I applied that pattern to a shape and ran into a few problems:

- During editing the tiling image is very low resolution. I have that with an image frame but at least there I can fix it by Item/Preview Settings/Full resolution.

- In print preview or PDF export the pattern stays blurry but also has gaps between the tiles. The image is tiling seamlessly.

Here is a screenshot where you can see both the editing window and the print preview:
http://zoltane.com/temp/Clipboard%20Image%20%2885%29.png

The thing image is the original, the shape next to it is the one with the pattern.

a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1295
  • Karma: 19
    • the graphics lab
Re: Image pattern: Gaps, low resolution
« Reply #1 on: April 10, 2016, 08:30:11 pm »
hi

in the screenshot i see the print preview, not a pdf viewer...

the print preview has not much to do with what you will get in a pdf... and might or not reflect what you will get at the end. (and, yes, it should show exactly the same content, but this is not really very helpful for you, if you have a workflow based on PDFs: most of all, depending on the PDF options, your document might be rendered with some differences).

can you share a .sla showing the issue?

ciao
a.l.e

ZoltanE

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Image pattern: Gaps, low resolution
« Reply #2 on: April 11, 2016, 08:06:46 am »
The pdf export doesn't have the low res look of the print preview but they both display the gaps between the tiles.

Here is the project: http://zoltane.com/temp/temp.zip

GarryP

  • Hero Member
  • *****
  • Posts: 1407
  • Karma: 21
  • Scribus User
Re: Image pattern: Gaps, low resolution
« Reply #3 on: April 11, 2016, 12:34:25 pm »
I have a sneaking suspicion that some kind of rounding error is to blame.

I quickly changed the X and Y resolutions of your image - using GIMP - from 299.999 to 300, then saved the new image. I then put the new image into the existing placeholder and created the new pattern from that selecting the new pattern from the fill tab. The stripes are now evident on the screen.

I then changed the resolutions to 72, saved, created another new pattern and the lines have gone from the normal screen view but are again evident in the print preview. However, they are not evident in an exported PDF.

I would suggest that this is a bug but would also suggest using 72dpi images for patterns, they usually work fine.

ZoltanE

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Scribus User
Re: Image pattern: Gaps, low resolution
« Reply #4 on: April 11, 2016, 12:42:48 pm »
Ah, interesting... For now I hackfixed it by repeating the pattern several times in a new image and using that. In the future however I'll make sure the patterns are based on 72 dpi images. Thanks!

GarryP

  • Hero Member
  • *****
  • Posts: 1407
  • Karma: 21
  • Scribus User
Re: Image pattern: Gaps, low resolution
« Reply #5 on: April 11, 2016, 02:25:26 pm »
I'm not saying that using 72ppi is a proper fix - for the user it shouldn't really matter except for image quality - it's just that it's worked for me in the past so that's what I normally use.