next question: why do you have a custom qt5?
This is a long story of development experiments ...
Quite separately from Scribus I wanted to experiment with Qt 5.* + Python bindings (PyQt) for app development (aiming at desktop initially). Previously I had Qt 4 on Ubuntu. I now have Qt 5.5.1 + PyQt + eric6 IDE working.
I also wanted to install latest Scribus for project documentation although I have Scribus 1.4.3 svn installed..
I have the Qt packages as listed here ..http://askubuntu.com/questions/508503/whats-the-development-package-for-qt5-in-14-04
But .. the Ubuntu 14.04 repo stops at Qt 5.2.1
The reason I opted for installing Qt 5.5.1
is the eric6 IDE dependency
While attempting to install latest eric6 IDE
, with earlier version of Qt installed, I encountered this error ..
"Sorry, you must have Qt version 4.8.0 or better or 5.3.0 or better".
So I decided to uninstall Qt 4 and upgrade (manually) to Qt 5.5.1 and then install latest PyQt snapshot and eric6 IDE.
I purged all older Qt versions and now have Qt 5.5 Creator working as before. Qt 5.5.1 examples work. PyQt works. eric6 IDE works.
Then I attempted to install Scribus-ng/Scribus-trunk and hit the 'xcb' plugin roadblock as reported earlier.
My latest attempt to correct this is to place a qt.conf file in same folder as scribus executables (/usr/bin).
But that didn't help. same plugin error seen.
The confusing point is that scribus wiki http://wiki.scribus.net/canvas/Building_SVN_versions_with_CMake#Version_1.5.x
reads ... dependency .. Qt (version >= 5.2
; see below for details)
If I were to now try purging Qt 5.5.1 what earlier version of Qt would work with scribus-ng (the binary)?