Scribusoid

Author Topic: Image Frame does not work with PDF files  (Read 1057 times)

fongchun

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
  • Scribus User
Image Frame does not work with PDF files
« on: September 13, 2015, 04:17:26 am »
Hi,

I am using Scribus 1.5 on my Mac OS X Yosemite 10.10.5. I have a test-1.png and a corresponding test-1.pdf file (attached). When I try to use the "Insert -> Image Frame" and choose the pdf file, it doesn't appear in my Scribus document. It complains about the file missing or is corrupt even though it can preview it.

When I try the same procedure with the test-1.png it shows up no problem. Interestingly, when I export the document as a PDF then start a new document and try to image frame the exported PDF the same error appears. Is there an issue with my workflow?

I've attached test-1.png, test-1.pdf, and Document-1.sla file with the image frames.

Thanks

utnik

  • Hero Member
  • *****
  • Posts: 1052
  • Karma: 12
Re: Image Frame does not work with PDF files
« Reply #1 on: September 13, 2015, 10:32:41 am »
hi fongchun

on my system it works wit both frames.
do you have 'ghostscript' installed on your machine? – it's needed to deal with placed .pdf files.

utnik

chai

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
  • Scribus User
Re: Image Frame does not work with PDF files
« Reply #2 on: November 04, 2016, 03:34:11 pm »
I experienced the same PDF image 'missing or corrupt' issue and the resolution was to resave the PDF as version Acrobat 5.x. Scribus then displayed the PDF preview image with the newly created file.

Scribus does not work with PDF files that are version Acrobat 6.x and higher.

I am using Scribus 1.4.6 on Windows 10. I also have Ghostscript 9.20 for Windows (64 bit) installed. Both of these are the current/latest software versions.