Author Topic: Text frame not keeping font selection  (Read 1490 times)

nathbeadle

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
  • Scribus User
Text frame not keeping font selection
« on: March 05, 2015, 12:43:43 am »
Normally I can find what I need but this is the first time it seems I'm the only one with this problem (or have problematic eyes and the solution is already posted somewhere).

Over different versions and across different OSes I've noticed a very annoying thing when using Text Frames. I'll create a new text frame, type in some content and then set the font and size and alignment in the Properties window/dialog. Later on I'll come back to edit it by adding some more text at the end of a line/paragraph within the frame.

If I start typing at the end of the line or if I hit return to start a new line and type the font defaults back to Arial and 12pt and I have to continually change the font settings.

To get around this I'll just start typing one character before the end of a line and that seems to inherit the font properties set and then when done just delete the extra character on the end of my typing.

Anyone else experience this or know what's going on or even better how to stop this from happening? Thank you in advance!

Nermander

  • Hero Member
  • *****
  • Posts: 1145
  • Karma: 15
Re: Text frame not keeping font selection
« Reply #1 on: March 05, 2015, 08:21:57 am »
I haven't looked at it but there are default settings for the frame. If you change the text properties for the text in the frame but not the default text properties for the frame I think you get that behavior.

Usually the best way to avoid issues like this is to always use styles (and apply them).


a.l.e

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1300
  • Karma: 19
    • the graphics lab
Re: Text frame not keeping font selection
« Reply #2 on: March 05, 2015, 08:44:43 am »
hi nathbeadle

sadly this is how scribus behaves. as far as i can tell, it's due to formatting model the team has chosen and is defending.

the model by itself is somehow correct, but it fails in a few everyday uses like this one.
well, the sad part, is that you get used, never to write at the end of a line.
at least not when you have local formatting!

(from my recalling: the problem is that the end of line mark and the frame have properties. they should not. except when they need to have it (when a frame is emptied; not sure about the paragraph mark)).

p.s.: i've copied your post to the repository where i'm starting to collect feedback from users... if you don't want it there, please drop me a line.
https://github.com/aoloe/scribus-feedback/blob/master/content/2015/forum-nathbeadle-formatting-at-end-of-frame.md

nathbeadle

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
  • Scribus User
Re: Text frame not keeping font selection
« Reply #3 on: March 05, 2015, 07:52:38 pm »
Thank you both for feedback and advice, appreciate it very much. I'm happy to know it's not just my installation/setup and will continue on the way I've managed as well as looking into styles. Very helpful!

Malsasa

  • Newbie
  • *
  • Posts: 10
  • Karma: 0
  • Scribus User
Re: Text frame not keeping font selection
« Reply #4 on: March 27, 2015, 04:22:39 am »
and I have to continually change the font settings.
Same with me. Scribus 1.4.4 SVN Ubuntu 12.04. Now after reading this thread, I know it is the workflow. I will follow you.